Table of FContents

Table of Contents

What’s New v3

1. Overview

2. Main Interface

2.1 Working with TARP Objects

2.2 TARP Toolbar

2.3 Entering Filenames

2.4 Using the Working Node List

2.5 Adding Nodes to TARP Objects

2.6 Working With Nodes in a TARP Object

2.7 Saving and Loading Sessions

3. Preferences

4. WorkBook Properties

4.1 Including Node Descriptions

4.2 Update Existing Data

4.3 Creating HeatMaps

5. Additional Files

5.1 ExcelOutputFile

5.2 InputFile

5.3 LimitFile

5.4 WeightingFile

5.4 UnitConversionFile

6. DataSets

6.1 Supported Formats

6.2 Converting Units

6.3 Data Limitations

6.4 Filtering Nodes and Timesteps

6.5 Defining the Last Cycle

6.6 DataSet Output

7. Groups

7.1 Group Filters

7.2 Fast Creation of Groups, Promoting, and Demoting

7.3 Group Output

8. Parameters

8.1 Parameter Output

9. Plots

9.1 Axis Properties

9.2 Series Properties

9.3 Plot Output

10. StripCharts

10.1 Axis Properties

10.2 Series Properties

10.3 StripChart Output

11. Tables

11.1 Defining the Operation and Source Sheet(s)

11.2 Defining the Parameter and Adding columns to the Table

11.3 Table Preview

11.4 Applying Conditional Formatting

11.5 Table Formatting Options

11.6 Table Output

12. Graphical Tables (TARP Pro only)

12.1 Defining the Limits and Data

12.2 User Points

12.3 Graphical Table Output

13. RadkManipulations (TARP Pro only)

13.1 File and Action Selection

13.2 Conductor Selection

13.3 Generating the Output

14. RadkCompares (TARP Pro Only)

14.1 RadkCompare Output

15. Backloads and Equivalent Sinks (TARP Pro only)

15.1 Specifying the Backload/EqSink Inputs

15.2 Creating and Using the Backload/EqSink Outputs

15.3 Backload/EqSink Calculations and Derivation

16. HeatMaps

16.1 Creating a HeatMap

16.2 Controlling the HeatMap Output

16.3 Dynamic Groups

16.4 Group to Group Heat Flow Matrix

16.5 Transient HeatMaps

16.6 Compare HeatMaps

17. Binary HeatMap Files (TARP Pro only)

17.1 Creating the Binary HeatMap File

17.2 Entering Files and Nodes

17.3 Adding Nodes to Sub-Network

17.4 Internal Storage in Workbook

18. Session Files

18.1 Session File Data Types

18.2 WorkBook Properties

18.3 Additional Files

18.4 DataSets

18.5 Groups

18.6 Parameters

18.7 Plots

18.8 StripChart

18.9 Tables

18.10 Graphical Tables

18.11 RadkManipulation

18.12 RadkCompares

18.13 Backloads

18.14 Binary HeatMaps

19. Creating and Using the WorkBook

20. Miscellaneous


TARP v1

1. Overview

Thermal Analysis Results Processor (TARP) is a Windows® based, post-processing tool that interfaces with numerous commercial thermal solvers. The basic approach of TARP is to allow the user to define objects within the TARP environment, which are then used to create a Microsoft Excel® workbook containing the objects defined by the user. TARP is available in two versions: TARP and TARP Pro, with the TARP Pro version offering more objects for data processing.

The TARP main interface (shown below) is where all objects are defined. From the main interface, the user defines the properties of the output workbook, specifies additional files to be included, creates DataSet, Group, Parameter, Plot, StripCharts, and Table objects, adds/removes data from the objects, and creates the resulting workbook. TARP Pro users have the additional ability to create RadkManipulation, RadkCompare, GraphicalTable, Backload/Equivalent Sink, and Binary HeatMap File objects. Once the session is defined, it may be saved to a session file for later modification or retrieval. The Make XL button is used to generate the workbook.


What’s new in Version 3

· Added StripCharts as TARP/TARP Pro feature

· Added RadkCompares as TARP Pro feature

· Checks included to ensure that Plot and StripChart Axes’ Major Divisions do not exceed data range or create excessive gridlines

· Default Max and Default Min for Plots and StripCharts now determines appropriate integer multiples of Major Division for Axes values

· Allow user to include up to 6 User Points on Graphical Tables and to define Color, LineType, and Weight of Error bars

· Increased levels of child groups from 3 to 5

· User may now opt to be prompted to Remove or Promote deleted child groups

· Added options for user to control number of columns of groups for Excel output

· Added Weighting value for Group calculation. Use may select either node capacitances (SS or Transient average) or a user defined weighting file

· Added option for TARP to calculate Groups and Parameter values instead of Excel (much faster but loses automatic recalculation capability)

· Groups now allowed to be added to Backloads/Eq Sinks (previously only nodes were calculated)

· Group Eq Sinks weighted by Radk Sum

· Added support for lower temperature constraint and grey-body sink estimation

· Added support for T^4 averaging for Eq Sinks

· Added ability to add nodes and/or groups to binary HeatMaps. Groups are internally dereferenced to their constituent nodes. Any connections to specified nodes are included in the sub-network; all other connections are ignored. Useful for very large models or specific areas of interest.

· Added trace levels for Binary HeatMaps with nodes that traces out up to 5 levels of heat paths (or until terminated by specified boundary nodes) from base set

· Added option in HeatMaps to only calculate and store user specified combinations of Node-to-Node, Node-to-Group, Group-to-Node, and Group-to-Group heatflows

· Allow main process to run in background thread for better feedback at main GUI during run

· Support for Excel 2007 added

· Fixed various other bugs

What’s new in Version 2

· Added Binary HeatMaps as TARP Pro feature

· Added RadkManipulations as TARP Pro feature

· Added GraphicalTables as TARP Pro feature

· Added Backloads (and Equivalent Sinks) as TARP Pro feature

· Added “Make Max/Mins for Groups” to create MaxGroup and MinGroup Parameters for all defined Groups

· Table Max/Min Columns now reflects the MaxGroup/MinGroup parameter for a Group entry if it exists

· Added Expand.exe function to expand INCLUDEd/INSERTed files in TMM

· Added Collapse.exe function to compress INCLUDEd/INSERTed files in TMM

· Added ToCSV.exe to convert TMM output files to Comma Separated text file

· Added utility to identify Duplicate Conductor Numbers in SINDA file

· Improved selection capabilities in Working Node List

· Added option to Select All Groups in Working Node List

· Made significant improvements in calculation speed of Max/Min Parameters

· Allow reordering and grouping of nodes in objects

· Ability to modify existing group relations in GUI (e.g. make existing group a child of another)

· Nodes to be included in a Group may now be specified via a filter string

· Added capability to modify groups within Excel, update Workbook, and save group definitions to external file for later use in TARP

· Added Transient HeatMap capability

· Added TARP menu to output workbook to allow user to run macros to Update Groups, Make HeatFlow Matrix, Re-Calculate HeatMaps, and output Transient HeatFlows

· Table subheadings may now be shown as row grouping at left side of table

· Added Toolbar to main interface

· Improvement in speed for table creation

· Fixed various other bugs


2. Main Interface

The main interface for TARP is where the user defines the properties of, and objects to be included in, the output Excel® workbook. The user first selects any Workbook Properties as desired. Objects are then added to the session through the TARP Objects tree. Nodes for the current DataSet, as well as any defined Groups or Parameters, are displayed in the Working Node List. Filtering is used to display only nodes meeting the specified criteria. From here, a subset of nodes is easily selected from the Working Node List and added to objects in the TARP Objects tree. As objects are selected in the TARP Objects tree, the nodes associated with the selected object are shown in the Nodes in Current Object listbox.

2.1 Working with TARP Objects

The TARP Object tree is where the user adds TARP objects to the current session. Available TARP objects include:

ObjectType | HasProperties | HasNodes | Availability
DataSet | Yes | No | TARP
Group | Yes* | Yes | TARP
Parameter | No | Yes | TARP
Plot | Yes | Yes | TARP
StripChart | Yes | Yes | TARP
Table | Yes | Yes | TARP
GraphicalTable | Yes | Yes | TARP Pro
RadkManipulation | Yes | No | TARP Pro
RadkCompare | Yes | No | TARP Pro
Backload | Yes | Yes | TARP Pro
Binary HeatMap File | Yes | Yes | TARP Pro

* Since groups only contain one property (GroupFilter), the property form displays the GroupFilter property for all groups rather than the single group that is selected

To add an object, the user right clicks in the TARP Objects tree to bring up a Context menu, shown to the left. If the user selects a specific object type (e.g. Add DataSet), then that object type is added. If the user selects Add Object, then the new object type is based on the currently selected object in the TARP Objects tree (e.g. if a Plot is selected, then a new Plot is created). If multiple objects are to be created at once (e.g. 5 Tables), the user first toggles the Add Multiple option on and then adds the object. When this option is checked, TARP prompts the user for the number of objects to create. Objects may also be deleted from the tree if they are no longer needed by selecting Delete Object or pressing the Delete key. When adding a Parameter the parameter type must be further specified as described in the Parameters section. As objects are added to the tree, they are placed into the correct grouping (e.g. DataSet into DataSets, Plot into Plots, etc). One exception to this is the creation of Groups, since Groups may be nested up to three levels deep. If an existing Group is selected in the TARP Objects tree when a new group is created, the new Group is added as a child to the currently selected group. If an existing Group is not selected in the TARP Objects tree when a new group is created, then the new Group is added at the root level under Groups. Groups may be promoted/demoted by appending them to other existing groups using the Make Child Group of or Make Sibling Group with options.

The names of each DataSet, Plot, Table, and Graphical Table translate to sheet names in the resulting output workbook, and therefore must be unique. The Group and Parameter names translate to additional data points and must also be unique (but may duplicate sheet names). To rename an object from its default name, the user selects the object to rename, pauses for a moment, and clicks the object again. At this point, the name is selected in a local textbox and is able to be changed by the user. For DataSets, the name may also be modified by changing the XL Sheet field. All objects except Parameters have additional properties to fully define the object. These are accessed by double-clicking the object in the TARP Objects tree. The sheet name may also be changed on the properties form for each object. Properties for Groups are a special case; accessing the properties forms for Groups allows the user to update the Group Filter strings for all of the groups and not just the currently selected group. RadkManipulation, Backload, and Binary HeatMap objects generally create external files to Excel and therefore are not typically represented as sheets in the output workbook. Exceptions to this include the List to Excel Sheet option for RadkManipulations and the Output Backloads to Excel Sheet and Output Equivalent Sinks to Excel Sheet options in Backloads. With these options selected, backloads are output to a sheet name based on the Backload object name with “_BL” appended; equivalent sinks are output to sheet name based on the Backload object name with “_Snk” appended.

2.2 TARP Toolbar

A toolbar (shown above) is available to perform the most frequently used functions. The left three buttons are used to create a new, open an existing, and save the current session. The next block of buttons is used to add the various TARP objects to the session. The buttons represent, from left to right, a new DataSet, Group, Parameter, Plot, StripChart, Table, GraphicalTable, RadkManipulation, RadkComapre, Backload, and BinaryHeatMap file. Selecting the Parameter button displays a popup menu for the user to select the type of parameter to create. The next button group allows for the creation of groups from submodels, the loading of groups from a file, and createing MaxGroup and MinGroup parameters from Groups. The next button is used to access the properties for the currently selected object. The last button is the equivalent of the Make XL button and is used to create the workbook once all objects have been defined.

2.3 Entering Filenames

When a DataSet or Additional File is selected in the TARP Objects tree, the Filename field is enabled for input, and the currently associated filename (if any) is displayed. Furthermore, for a DataSet, the Format and XL Sheet fields are enabled and display their respective data. Selecting the browse button [image] prompts the user for the filename to associate with the selected DataSet or Additional File. The selected file may also be viewed in a Text Editor (or Excel® for the output file) by selecting the preview button [image] .

When a new file is selected for a DataSet, TARP attempts to determine the format (e.g. SINDA85, ESATAN, etc.) based on a header found in the first lines of the file. If the determined file format (e.g. SINDA/G) matches the displayed format (e.g. SINDA/G-Q), then the Format field is not changed. However, if the determined format (e.g. SINDA/G) does not match the displayed format (SINDA85-Q), then the displayed format is updated with the assumption that the user will process temperatures (SINDA/G-T). The format may always be changed after the file is selected. The XL Sheet field shows the name of the DataSet, which defaults to Data1, Data2, Data3, etc. unless the Sheet Names Same as Filenames preference is enabled (through the Preferences form). If this option is enabled, then the DataSet name is based on the base filename, as long as no duplications occur (e.g. two DataSets with the same filename).

2.4 Using the Working Node List

Once the filename for a DataSet has been selected, the nodes or conductors contained in the file are displayed in the Working Node List. This list may be filtered by entering the desired range in the Node Filter; only entries meeting the user-specified criteria are then displayed in the Working Node List, allowing the user to display only a subset of interest. Values may be entered as either single values (SUB.100, 200) or ranges (SUB.1-100, 1-200), with multiple entries separated by commas (1-10, SUB.20). If no submodel is specified in a filter entry, then any values meeting the criteria are displayed, regardless of submodel (e.g. 1-10 would display INST.1 or SC.1). If a SINDA85 model is loaded, then a list of submodels from the file is stored in the Node Filter combo box for quick filtering. If Groups are defined, then a Not In Group option exists to show all nodes not included in a group. All defined Groups and Parameters are displayed at the beginning of the Working Node List, regardless of the filter criteria. Options exist in the Preferences to display only nodes, Groups, Parameters, or any combination thereof in the Working Node List. This may be helpful if a user wishes to only work with groups or nodes. The Working Node List is intended to be a frequently changing list as the user decides which nodes and conductors are needed for which objects and changes the list accordingly.

A user may also load a node selection file if desired. Clicking the Browse button to the right of the Node Filter [image] prompts the user for a .sel file. This file is processed and each line is one entry in a filter criteria string. The file name is then displayed in the Node Filter combo-box and the nodes in the Working Node List are filtered accordingly. To preview or modify this file, the user may select the preview button to the right of the Node Filter [image] .

2.5 Adding Nodes to TARP Objects

When the user has selected a collection of desired nodes, Groups and Parameters in the Working Node List, they may then be added to a TARP object via two methods. The first is to select the desired nodes and right click to display the Context Menu shown to the left. From here, the user may add the selected nodes to the current object or specify the object through the menus. The second method is to drag them from the Working Node List and drop them onto the desired object in the TARP Objects tree. Not all object types accept inputs from the Working Node List; DataSets, Binary HeatMap Files, and RadkManipulations do not include nodes as part of their definition. Furthermore, Groups cannot accept another group or parameter for inclusion, only nodes. If nodes have been added to an object, but are no longer desired, they may be deleted from the Working Node List by pressing the Delete key or selecting the Delete Selected/Delete Unselected options. Capabilities also exist for the fast creation of Groups and Parameters. Groups may be created based on the submodels (for submodel supported output) or loaded from an existing file. This is discussed further in the Groups section. MaxGroup and MinGroup parameters may also be automatically created for all defined groups by selecting the Make Max/Mins for Groups option.

2.6 Working With Nodes in a TARP Object

When an object is selected in the TARP Objects tree, or when nodes have been added to the current object, the associated nodes are displayed in the Nodes in Current Object listbox. For Plots, additional information is also shown in the Nodes in Current Object listbox for each entry, including the source DataSet for the series and the plot axis (Primary or Secondary). StripCharts similarly show the Source and Sub-chart. For a Difference Parameter, an additional “+” or “–” prefix is shown to indicate that one node is subtracted from the other. A Context Menu (accessed by a right click) allows the user to further manipulate the nodes in an object. Nodes may be reordered, selected, deselected, or removed from an object. Node selection may also be saved to an external file for later use by the Node Filter in retrieving the same node sets in another session. Furthermore, the order of the nodes may be changed by selecting the desired node(s) and clicking Move Up or Move Down. Alternately, this may be accomplished using the up/down cursor keys while holding the Alt key down. The selected nodes may also be grouped together to combine related nodes. For example, if nodes 1-6 were included in the list and all the odd nodes were selected, selecting Group Selected would then combine all the odd nodes sequentially. As a result, the even nodes would be moved to the end of the selected nodes, resulting in a 1,3,5,2,4,6 ordering. This is useful for grouping together related nodes (e.g. for a particular subsystem or component) without having to add them to the list in the desired order.

Object specific modification capabilities are also provided. If the current object is a Plot, then the user is able to change the source DataSet or the plotting axis for any series. If it is a Table, then the user may insert Table SubHeadings (see Table Output for an example). If the current object is a Group, the nodes defined in the group may be promoted into its parent group or demoted into existing or a new child group. Lastly, if the current object is a Difference type parameter, then the order of the two nodes may be reversed. Each of the options beneath a blue line in the image is only available for appropriate object types.

2.7 Saving and Loading Sessions

Once all the objects are fully defined in the TARP environment, the session may be saved for later use. Under the File menu, the user has options to Save, Open, Edit, or create a New session file. The session files are simple ASCII files that store all properties for every object defined. Further information is found in the section on Sessions. The four most recently opened or saved sessions are also displayed under the File menu.


3. Preferences

A number of preferences to control the behavior of the TARP interface and output workbook are accessible under the Tools menu. The General Tab allows the user to set the Text Editor to be used for previewing files. An option is also available for displaying full paths to filenames or simply the basename and extension. This is useful when a file is nested many directories deep and the filename cannot be seen in the text box without scrolling. If the user is only interested in working with Nodes, Groups, Parameters or combinations thereof, options are available to display only the selected entity type(s). Debug modes also exist, which report numerous breakpoints in the code to indicate progress. This is intended to be used to help troubleshoot locations in the code where an unhandled exception may have occurred, without the need for a user to provide files to the software vendor for debugging purposes (e.g. proprietary models).

For DataSets, the Formats to Show frame has a listing of all supported output file formats. Only those that are checked are displayed in the Format field at the main interface and the DataSet properties form. For example, if a user only needs SINDA/G outputs, then all other formats could be removed from the display by unchecking all options except SINDA/G. Default units for DataSets may also be set and applied to all new DataSets. An option also exists to Compress Non-Varying Conductor Output. This saves significant space in the output workbook, as a constant conductor is only output once, instead of at each timestep. Lastly, the Excel® SheetName may be automatically set to the base name of the file. This capability may not function if the same filename is used for multiple datasets (e.g. Temp and Heat from same file).

As nodes are added to an object from the Working Node List, they may be automatically removed from the Working Node List as they are added to a Plot, Table, or Group. This is helpful to see what nodes remain that have not yet been included on a Plot, Table, or Group. The default series characteristics for plots are also displayed, including: line type, color, weight, marker symbol, fore color, backcolor, size, shadow, and frequency. While these values cannot be changed here, it does provided a simple view of what values will be assigned to series as they are added to a plot. The values themselves are defined at the Plot Properties form for any plot.

Tables include an option for the creation of Dynamic Columns. This allows the user to define the source sheet and source parameter for each column of simple values by selecting the appropriate values from dropdown listboxes.

For groups, an option exists to either delete subgroups when a group is deleted or promote the subgroups up to the next level or to prompt the user when a group is deleted. The Maximum allowable group level controls how many columns to allocate for groups on the DataSet worksheets. If Auto is selected, then the maximum level of subgroups determines the number of columns (e.g. 2 columns if groups only go to Minor level). An option also exists to prevent a Divide by Zero error for weighted group calculations, when the sum of weighting factors for a group is zero. Furthermore, nodes displayed in a group may be controlled to either display only the nodes defined in the group, or to include all nodes contained in child groups of the selected group. The option to Allow Group Modifications Within Excel is used to signal to TARP to create the workbook from the template which includes the macros to allow the user to access the group modification from within Excel as described in Creating and Using the Workbook.

Lastly, some options exist to improve the performance of TARP. Running the main calculations in a separate thread allows the main interface to update even when the screen is moved, resized, or minimized or when other windows are dragged over top of it. The user may also opt to expose the Excel workbook during TARP execution. This may be useful if TARP encounters an error to see how far it has gotten in the creation of the workbook. Lastly, Allowing TARP to Calculate Groups and Parameters may be much faster than relying on Excel. The formulas for Group lookup and calculation, as well as Parameter calculation are preserved as the first row (for Group Lookups), the row containing the first Group (for Group Calculation) and the row containing the first Parameter (for Parameter Calculation) should the user need to re-evaluate the formulas due to a group definition change.


4. Workbook Properties

Properties for the workbook are selected under the WorkBook Properties branch in the TARP Objects tree. Selected options are indicated by an (x). Clicking the option toggles the value between selected and not selected. Available workbook properties include: Include Node Descriptions, HeatMap, Compare HeatMap, and Update Existing Data.

4.1 Including Node Descriptions

The Include Node Descriptions option requires either the thermal model input file (for SINDA85, SINDA/G, and TAK2000) or a PRNDTB call for ESATAN output. For thermal model input, two types of comments are processed: in line comments, and block comments. For the following NODE DATA section, the in-line comments are what appear after the comment character ($), and the block comments are what appear before the block of nodes. Therefore, “Panel Nodes” is the Block description for Node 10, and the in-line comment is “Upper Panel”. For ESATAN, a PRNDTB is expected prior to any other calls with the ‘L’ zent included. For TMG, no option currently exists to associate nodes with descriptions.

C    Panel Nodes

C

       10, 10.0, -1.0   $ Upper Panel

       20, 10.0, -1.0   $ Lower Panel

The outputs from this data are stored on the NodeInfo sheet created in the output workbook. The first two columns (A and B) are reserved for the Block Description and the Node Description respectively, while the third column displays the node number. This range of data in Excel® is subsequently used by Tables, Graphical Tables, and HeatMaps to display the Node Description along with the node number. Should the user wish to change this data, it need only be changed on the NodeInfo worksheet to propagate to all other references throughout the workbook.

4.2 Updating Existing Data

The Update Existing Data option allows the user to update only the data contained in DataSets. It does not generate any of the other objects specified in the session. Upon specifying an Excel Output File with this option enabled, the specified workbook is scanned to determine the names of all existing sheets. If the specified worksheet name already exists, then only the data is updated; the Group, Minimum, Average, and Maximum formulas are not updated. However, if a new worksheet name is specified, then this sheet will be added to the workbook and will include the Minimum, Average, and Maximum formulas as well as the Group definitions. If plots or tables exist in the output workbook, then the data needs to be in exactly the same order and have the same number of timesteps to ensure that all Plots/Table formulas still reference the correct rows and columns.

4.3 Creating HeatMaps

The HeatMap and Compare HeatMap options create a specialized, interactive workbook to investigate heat flow between nodes and/or groups of nodes. This workbook type requires Temperature, Heat, and Conductor data for each output timestep. Upon selecting the HeatMap option, TARP Pro users are prompted to create DataSets or Binary HeatMap Files. TARP users automatically default to DataSets. If DataSets is selected for the HeatMaps, all existing DataSets are deleted and three pre-defined DataSets are created: Temp, Heat, and Cond. Similaryly, selecting the Compare HeatMap option with DataSets removes all existing DataSets and creates 6 pre-defined DataSets: TempA, HeatA, CondA, TempB, HeatB, and CondB. Additional DataSets may not be created or existing DataSets deleted when HeatMap options are enabled. For further information, see the HeatMaps section.

Certain combinations of Workbook properties are not allowed. For example, selecting the HeatMap does not allow the user to also select Compare HeatMap. Furthermore, selecting either HeatMap option automatically enables the Include Node Descriptions option, as the input file must be processed for Node Descriptions used in the HeatMap output as well as the node pairs for each conductor (for SINDA85, SINDA/G, and TAK2000). For ESATAN output, the node pairs and node descriptions are available in the output file, therefore, the input file is not needed.


5. Additional Files

Additional files may also be needed to create the workbook. The Excel Output filename, Thermal Model input file(s), user Limit File, and Unit Conversion files may all be specified and used in the creation of the final workbook.

5.1 Excel Output File

The ExcelOutputFile specifies the path to the output workbook generated by TARP, which is blank by default. If the value is blank and a file for a DataSet is selected, then the ExcelOutputFile is updated to have the same base name and path as the filename specified for the DataSet. If the user then selects another file for the first DataSet, the ExcelOutputFile is not changed unless it was made blank prior to the second file selection. Therefore, some care should be taken when continuously working in the same session. Creating a new session resets the ExcelOutputFile to a blank value. It is recommended that the user explicitly specify the ExcelOutputFile file, but the default behavior allows for a meaningful name to be assigned to the output workbook if the user does not specify it explicitly.

5.2 Input Files

The InputFile(s) are used for two separate sub-tasks. If the user has enabled the Include Node Descriptions workbook property, then the input file is used to extract the node descriptions. Furthermore, if the user has specified the HeatMap or CompareHeatMap workbook property, then the thermal model input file is necessary to extract the node pairings for each conductor for SINDA85, SINDA/G, and TAK2000.

5.3 Limit File

The LimitFile is a user-created file that defines limits to be applied to nodes in a comma-separated format. The first line of this file should include the word Node followed by the limit names desired by the user. Once a LimitFile is specified, the limit names, as defined on the first row, are available for inclusion in any table or graphical table. A sample format is shown below.

Node, Red High, Yellow High, Yellow Low, Red Low

INST.1, 45, 40, -30, -35

INST.12, 40, 30, -30, -40

…

5.4 Weighting File

The WeightingFile is another user-defined file that specifies theweighting factors to apply to each node for the purposes of calculating an average temperature that is representative of the group. The Group temperature is calculated from Tgroup=(S(wi*Ti)/ Swi). Weighting factors can be used to more heavily favor some temperatures and neglect others. For example, the temperature of a massive diffusion node might be more relevant than an MLI node for groups with both nodes.

A common and quick method to select relevant nodes is by nodal capacitance. Two options are available to evaluate and apply the nodal capacitance as the weighting factor: capacitance based on steady state temperatures and orbit average capacitances. Once these values have been read from the selected file, they are displayed in the form. Upon closing the form, the user is prompted for a file to save the data for later use. Arithmetic nodes are assigned a zero weighting factor; boundary nodes, being of infinite mass are excluded by also assigning a zero weighting factor.

5.5 Unit Conversion File

The UnitConversionFile is another user-defined file that specifies the necessary coefficients to convert from one set of units to another for DataSets. The following Unit conversion coefficients are included; should the user need units not supplied, this file may be modified to include new unit sets. However, it is advised to include unit conversions for all other units available for the Unit Type. (i.e. if the user adds a new heat unit, include conversion to all other existing heat units)

Unit Type

From Unit

To Unit

Unit Type

From Unit

To Unit

Time

s

min

Time

hr

s

Time

s

hr

Time

hr

min

Time

s

day

Time

hr

day

Time

min

s

Time

day

s

Time

min

hr

Time

day

min

Time

min

day

Time

day

Hr

Temperature

°C

K

Temperature

°F

°C

Temperature

°C

°F

Temperature

°F

K

Temperature

°C

R

Temperature

°F

R

Temperature

K

°C

Temperature

R

°C

Temperature

K

°F

Temperature

R

°F

Temperature

K

R

Temperature

R

K

Heat

W

J/min

Heat

BTU/hr

W

Heat

W

BTU/hr

Heat

BTU/hr

J/min

Heat

W

BTU/min

Heat

BTU/hr

BTU/min

Heat

J/min

W

Heat

BTU/min

W

Heat

J/min

BTU/hr

Heat

BTU/min

J/min

Heat

J/min

BTU/min

Heat

BTU/min

BTU/hr

Lin Cond

W/K

J/min/K

Lin Cond

BTU/hr/R

W/K

Lin Cond

W/K

BTU/hr/R

Lin Cond

BTU/hr/R

J/min/K

Lin Cond

W/K

BTU/min/R

Lin Cond

BTU/hr/R

BTU/min/R

Lin Cond

J/min/K

W/K

Lin Cond

BTU/min/R

W/K

Lin Cond

J/min/K

BTU/hr/R

Lin Cond

BTU/min/R

J/min/K

Lin Cond

J/min/K

BTU/min/R

Lin Cond

BTU/min/R

BTU/hr/R

Rad Cond

cm2

m2

Rad Cond

in2

cm2

Rad Cond

cm2

ft2

Rad Cond

in2

m2

Rad Cond

cm2

in2

Rad Cond

in2

ft2

Rad Cond

m2

cm2

Rad Cond

ft2

cm2

Rad Cond

m2

ft2

Rad Cond

ft2

m2

Rad Cond

m2

in2

Rad Cond

ft2

in2

Capacitance

J/K

W min/K

Capacitance

BTU sec/min/R

J/K

Capacitance

J/K

BTU sec/min/R

Capacitance

BTU sec/min/R

W min/K

Capacitance

J/K

BTU/R

Capacitance

BTU sec/min/R

BTU/R

Capacitance

W min/K

J/K

Capacitance

BTU/R

J/K

Capacitance

W min/K

BTU sec/min/R

Capacitance

BTU/R

W min/K

Capacitance

W min/K

BTU/R

Capacitance

BTU/R

BTU sec/min/R


6. DataSets

DataSets create Excel® worksheets that contain the raw data from the thermal model output file. The user has options to specify the Source File, Format, Parameter, and worksheet name. Further options are also available under the DataSet properties form, including: unit conversion, transposing of the output, selecting nodes for output, selecting timesteps for output, inclusion of additional output points (e.g. Minimum, Maximum, etc.), and the definition of the last cycle for cyclical output.

6.1 Supported Formats

TARP can process a number of commercial thermal solver outputs. For each of these, the common ASCII output from the various output subroutines (e.g. TPRINT for SINDA/G) can be processed, as well as output from some Radiation solvers. The following formats and parameters are supported:

Format | Parameters
SINDA85 & SINDA/FLUINT | T, Q, G, C
SINDA/G | T, Q, G, C, F
ESATAN (PRNDBL) | T, Q, QS, QA, QE, QI, QR, G, GL, GR, C
ESATAN (PRNDTB) | T, Q, QS, QA, QE, QI, QR
ESATAN (GFF) | T, Q, QS, QA, QE, QI, G, GL, GR, C
TMG | T, Q
TAK2000 | T, Q, G, C
TSS | Q, Q”, G*
ThermalDesktop | Q, Q”, G*
Comma, Space, or Tab Delimited | T, Q, G

* Planned Additions

6.2 Converting Units

Unit conversion is based on the conversion coefficients provided in the UnitConversionFile.csv specified under Additional Files. Only units applicable to the current parameter are displayed. The units available are based on those contained in the UnitConversionFile, as well as the conversion coefficients used in the resulting formulas. Both Linear and Radiative conductors may be converted independently. For heat flux from a Thermal Radiation output file (e.g. ThermalDesktop, TSS), the area component may also be converted independent of the energy term.

6.3 Data Limitations

By default, TARP outputs the data with each row representing a single node, group, or parameter. Correspondingly, each column represents a timestep. A limit of 256 columns and 65536 rows exists for any single worksheet. Since the first 3 columns are used for Major, Minor, and SubGroup definitions, and the fourth column is reserved for the node number, a maximum of 252 columns are available for output timesteps. This number may also be further reduced by the inclusion of up to 6 additional parameters: Minimum, Average, Maximum, Time Min, Time Max, and Delta. In general, 246 columns should be sufficient for the majority of model outputs. If the number of rows exceeds what can fit onto one sheet, additional sheets are created with the same basename and an incremental counter appended (e.g. Cond2, Cond3, etc.). Note that if data is written to subsequent sheets, any formulas referencing the DataSet (in Plots, Tables, Groups, etc.) do not recognize that data has been written to the subsequent sheets.

In some instances, it may be necessary to include more timesteps than allowed on a single sheet. For these cases, the output may be transposed, with each column representing a node/group/ parameter and each row representing a timestep. The user is then limited to 255 nodes/groups/ parameters. Should it be necessary to include more data than can fit onto a single worksheet, it is recommended to create multiple datasets with the required data.

6.4 Filtering Nodes and Timesteps

Selected nodes may be output using one of two methods. Selecting …Referenced Nodes outputs only nodes that are used in a Plot, Table, Graphical Table, Group, or Parameter; all unused nodes are not output. The second method is to explicitly specify the nodes to output using the …Meeting Filter Criteria option. In this case, all nodes are processed, but only those meeting the specified filter criteria are output. The filter criteria is based on the same rules for the Node Filter used at the main interface. Filter entries may be entered as either single nodes (SUB.100, 200), ranges of nodes (SUB.1-100, 1-200), or a combination thereof, with multiple entries separated by commas (1-10, SUB.20). If no submodel is specified in a filter entry, then any nodes meeting the criteria are displayed, regardless of the submodel (e.g. 1-10 would display INST.1 or SC.1).

Specific timesteps may also be selected for output by highlighting the desired timesteps in the Output Timesteps listbox. A user may output repeating patterns of timesteps using the Include/Skip values. An Include of 1 and a Skip of 1 would output every other timestep; an Include of 1 and a Skip of 4 would output every fifth timestep. This is useful to output the trends for numerous data points without having to output each point.

6.5 Defining the Last Cycle

The Last Cycle is used for cyclical output (e.g. 0-6000, 0-6000, 0-6000…) to define the time range for plotting and the range over which to compute the Additional Parameters. By default, TARP starts at the last timestep and checks if the preceding timestep is smaller. If so, it continues tracing back until a timestep value greater than the current location is found or a steady state result or initial condition is found. The user may over-ride the default selection by specifying their own range as the last cycle. Once this is set, the user may opt to include additional output such as the Maximum, Average, or Minimum over this range, the timesteps where these occur, or the Delta (Maximum-Minimum) over this range.

6.6 DataSet Output

Sample DataSet output is shown above. Cell D2 (or B4 if the data is transposed) includes a comment, indicated by a small red triangle in the upper right hand corner of the cell, that provides traceability for the output. This comment includes: the source file name, format, parameter, path, and size, as well as original and converted units, node filter criteria, and an indication if timesteps were filtered. Any converted data is displayed as the result of a formula. Therefore, the original raw data value is preserved in the formula (e.g. “=93.075 * 0.5555556 + -17.77778”); the conversion can be removed by performing a search and replace on the entire sheet for the conversion formula. Hint: to avoid the * being interpreted as a wildcard, replace “0.5555556 + -17.77778” with “1”.

In addition to the raw data, groups and parameters are also added to the data after the last node entry. The image to the left shows the relative location of information on a DataSet worksheet. The Group Lookups for each node are shown in Column A (MajorGroup), Column B (MinorGroup), Column C (SubGroup), Column D (Sub2Group), and ColumnE (Sub3Group). If the Auto option is selected under Maximum Allowable Group Level on the Preferences form, then the minimum number of columns needed to describe the groupings is output. The group lookups are determined using the MATCH and INDEX Excel® functions referencing the NodeInfo sheet. Therefore, changes in Group definitions made on the NodeInfo sheet are automatically updated on all DataSet sheets. The next column after the Group lookups is the Weighting value.

The computed group values (Group Data) are appended to the end of the node data block, with Group values representing the total heatload or the average temperature. These values are computed using the SUMIF and COUNTIF functions in Excel® as well as a SUMPRODUCTIF VBA function provided in the TARP.xls template workbook if Weighting values are used. If the option is unchecked under preferences to Return unweighted group average for groups where all nodes have a zero weighting factor and this condition is met, then the returned value will be a #DIV/0! Excel error. The Group List contains the unique names/levels defined by the user. Groups at the Minor level are preceded by 3 spaces, and groups at the Sub level are preceded by 6 spaces. If nodes exist in the same group name at multiple levels (e.g. nodes defined in Minor group are propagated to a Sub group of the same name), then the group name may appear more than once but with different spacing. This is needed to uniquely identify the group temperatures or heat loads at different levels if some nodes are included explicitly and some are included as members of a child group.

The Parameter List contains the listing of all parameter names, and the Parameter definition contains text needed to evaluate the parameter itself. The Paramater Data block contains formulas that call the tarpParameter function, which internally calls MAXIF and MINIF VBA functions, also provided in the TARP.xls template.

To the right of all Node/Group/Parameter data, additional data is appended as requested by the user. Most often, this includes Minimum, Average, Maximum, Time Min, and Time Max. These formulas use the MIN, AVERAGE, MAX, and the MATCH and INDEX functions for the TimeMin/TimeMax lookups.

If the option is checked under Preferences to Allow TARP to Calculate Groups and Parameters, then only the first row of the Groups block and the first row of the Parameters block contains the formula. This is also true for the Group and Weighting lookup formulas to the left of the node column. The formulas are included such that if any changes to the Group definitions are made on the on the NodeInfo sheet, the user has the capability to fill the formulas down, and once again allow Excel to calculate the values.


7. Groups

Groups are used to simplify larger models. Groups compute the average Temperature of, or total Heat Load on, all nodes contained in the group and all of its child groups. They are most powerful when combined with HeatMaps to determine heatflows into and out of the groups. As a group is added to the session, it is displayed in the Working Node List at the main interface and is treated as if it were any other node that may be added to a Plot, Table, or Graphical Table Plot. Nodes are added to a group in the manner described in Adding Nodes to TARP Objects. However, other groups and parameters may not be added to a group, only nodes. Alternately for groups, Group Filters may be used to define the nodes to include by specifying a range which is then resolved to determine the nodes in a DataSet that meet the filter criteria.

When a group is created, it is automatically made a child group of the currently selected group in the TARP Objects tree. If no group is selected, the group is added as a MajorGroup at the root level under the Groups heading in the TARP Objects tree. This is how multi-level groups are created in TARP. Groups may be nested up to five levels deep (Major, Minor, Sub, Sub2 and Sub3). These first three levels are intended to represent an Instrument:Region:Component hierarchy. In the group hierarchy tree to the left, the Panels group is a MajorGroup, with Outer and Inner child groups at the MinorGroup level. Furthermore, the Outer MinorGroup has OuterSides, OuterTop, and OuterBot as child groups at the SubGroup level.

A node is only defined in one group, but based on parent-child relations it is included in up to three groups (one at each level). If a node is defined in a MinorGroup, it is also included in its parent group as well as a SubGroup with the same name. The table on the left shows nodes 1 through 6, the group name where the nodes are defined, and the group containing the nodes at the Major, Minor, and Sub Group levels for the Panels:Outer:OuterSides path. The table on the right shows the resulting groups that are created by TARP for each level.

Node

Defined In

Major

Minor

Sub, Sub2, Sub3

Group

Level

Contains Nodes

1

OuterSides

Panels

Outer

OuterSides

Panels

Major

1,2,3,4,5,6

2

OuterSides

Panels

Outer

OuterSides

Panels

Minor

5,6

3

Outer

Panels

Outer

Outer

Outer

Minor

1,2,3,4

4

Outer

Panels

Outer

Outer

Panels

Sub

5,6

5

Panels

Panels

Panels

Panels

Outer

Sub

3,4

6

Panels

Panels

Panels

Panels

OuterSides

Sub

1,2

7.1 Group Filters

Group Filters provide a simpler method for defining groups if an organized nodal numbering scheme was used in the thermal model (e.g. 1-1000 is Inst1, 1001-2000 is Inst 2, etc.). Instead of explicitly adding each node to a group, a range (e.g. MAIN.1-100, MAIN.150, INST.1) may be entered at the Group Filter form, shown below. These ranges are then used to evaluate which nodes from output datasets are included in the group. For example, if (1) the range MAIN.1-100 is defined for Panels, (2) DataSet1 contains nodes 1-10, and (3) DataSet2 contains nodes 50-75, then Panels contains nodes 1-10 and 50-75, even if some of those nodes do not exist in all datasets. The inclusion of nodes that do not exist in all DataSets is allowed, since nodes not included do not have any contribution to the total heat load or average temperature formulas in Excel®. Resolving the Group Filters processes the current DataSets and assigns the appropriate nodes into the appropriate groups. This allows a user to see which nodes are included in a group and promote, demote, or remove them if necessary.

7.2 Fast creation of Groups, Promoting, and Demoting

For output with submodels (i.e. SINDA85 or SINDA/FLUINT), an option exists to create Major groups based on the submodels found in the output. A user may also load existing groups from a file. Nodes that are defined in a group may be demoted into a new child group or any existing child groups. Similarly, nodes in an existing group may be promoted into their parent group. These options are only allowed for nodes defined in the group. Nodes displayed in the Nodes in Current Object list may not be acted upon. Furthermore, groups themselves (not the nodes defined in them) may be promoted or demoted using the popup menu for the TARP Objects tree. This capability is described in Working with TARP Objects section.

7.3 Group Output

Sample Group output for a DataSet sheet is shown above. The actual group definitions themselves (i.e. which nodes are assigned to which groups) are stored on the NodeInfo sheet. These values are referenced by lookup formulas using the Excel® MATCH and INDEX functions to define the groups for each node on each DataSet sheet. The groups assigned to each node are shown in columns 1 through 4, with Column 1 showing the MajorGroup, Column 2 the MinorGroup, Column 3 the SubGroup, and Column 4 the Sub2Group. For this case, the Max Allowable Group Level option under the Preferences form was set to 4. The calculated group values themselves are shown at the end of the node data. Formulas for the group values use the SUMIF and COUNTIF Excel functions and the SUMPRODUCTIF VBA function provided in the TARP.xls template. Any changes made to group definitions on the NodeInfo sheet propagate throughout the workbook via the formulas.

Recall that nodes are defined in only one group, but can be included in up to three groups based on Parent-Child relationships. Therefore, group names at each level are appended to the end of the node data rows, meaning that a group name may appear multiple times, but at different levels. The level for the group is indicated to the left of the Group Name. Group names at the MinorGroup level are preceded by 2 spaces; SubGroup names are preceded by 4 spaces and so on. The hierarchy and ordering is also shown to display relationships between child and parent groups. In the data above, nodes defined in a MajorGroup are also included in a MinorGroup, SubGroup, and Sub2Group with the same name (as in the SPACE group above). Some group names may only exist at one level, where all the nodes included in the group are defined in child groups (such as the Panels group above). This preservation of nodes at all levels is necessary for ensuring that all nodes in a group are represented in HeatMaps, regardless of what the group level where they are defined. Groups that are plotted or tabulated are based on the first occurrence. For example, if the user requested the Space group above, then the Major level Space group would be displayed.


8. Parameters

Parameters return the result of a predefined formula applied to nodes contained in the Parameter. Five parameter types are supported: Difference, Min of Nodes, Max of Nodes, Min of Group, and Max of Group. The Difference parameter expects two nodes and returns the difference between them (Node2 – Node1). The Min/Max of Nodes returns the minimum and maximum value found in a collection of nodes respectively. The Min/Max of Group returns the Minimum and Maximum of nodes contained in the specified group. Similar to groups, each parameter created is available to be included in a Plot, Table, or Graphical Table.

8.1 Parameter Output

Sample Parameter output on a DataSet sheet is shown above. The parameter name is shown in the same column as Nodes and Group names. The column to the left contains a string value that defines the parameter type and the inputs to the parameter. If the parameter type is “Difference”, then native Excel® functions are used; for all other parameter types, a specialized VBA Function is called to compute the value for the parameter type, provided in the TARP.xls template.


9. Plots

Plots are graphical representations of data as a function of time. Each plot consists of a Title, an X and a Y axis (and possibly a secondary Y axis), and a collection of data series. Each series is represented by one line on the plot, which may have varying Line properties (LineType, Color, Weight) and Marker properties (Symbol, ForeColor, BackColor, Size, Frequency, and Shadow). The Plot properties form is shown below.

9.1 Axis Properties

The axes properties may be defined by the user including axis Maximum and Minimum, and Major and Minor Divisions. The Default Max or Default Min options determine the closest integer multiple of the Major Division for the Minimum and Maximum axes values. By default, both Major and Minor gridlines are displayed, unless the user sets the Major Division equal to the Minor Division. The axis titles and units are based on the source DataSets referenced by the Plot. If a DataSet is for Temperatures with units of °C, then the axis title reflects this. If two types of units are found on one axis, then both are indicated. A secondary axis is also available, but is only enabled if any series on the plot is set to the secondary axis. This is most useful for plotting two different units together on the same plot (e.g. Temperature and Heat to verify heater behavior). The axes properties may also be applied to all plots to ensure consistency across multiple plots.

9.2 Series Properties

The user also has control over individual series properties. Three types of series characteristics are available for modification: Data, Line, and Marker. Any changes made in the Series Properties frame are applied to all nodes selected in the Series List, allowing for multiple series to be changed at once. The Data characteristics include the Source DataSet and the axis on which to plot the series. Line characteristics include Line Style, Color, and Weight. The marker characteristics include Symbol, Fore Color, Back Color, Size, Shadow and Frequency. Marker frequency is the only option available through TARP that is not readily changeable in Excel®. This option allows a user to place a marker every so many data points for series that are very dense and would have too many overlapping markers to be able to distinguish the marker symbol. The table below shows the options available for each characteristic.

Style | Color | Weight | Symbol
Solid | Too numerous to list | Hairline | Square
Dashed | 56 Available | Thin | Diamond
Dotted |  | Medium | Triangle
Dash Dot |  | Thick | X 1
Dash Dot Dot |  |  | Star 1
Medium Density 2 |  |  | Dot 1
High Density 2 |  |  | Dash 1
Low Density 2 |  |  | Circle
 |  |  | Plus 1

1 - Indicates “Non Fillable” Marker

2 - Indicates that these options are not available in Excel 2007. Will be automatically converted to Solid if used

Certain options are available to help relate line and marker colors. The first option, Marker has same Fore Color as Line, automatically sets the marker Fore Color when the Line Color is changed. Furthermore, the Marker has same Back Color as Fore Color, sets the marker back color when the fore color is changed. The Set BackColor to None for Non-Fillable Markers option automatically sets the Back Color to None for X, Star, Dot, Dash, and Plus type markers. Lastly, the Apply Size/Freq changes to all Series option applies the Size or Frequency to all series when either of these options is changed.

Similar to axes properties, series properties may also be applied to all other plots to ensure consistency. However, since different plots can have different numbers of series, some care must be taken when using this feature. Assuming that Plot1 has 3 series and Plot2 has 7 series, applying series properties while on Plot1, would only affect the first 3 series on Plot2. Conversely, applying series properties on Plot2 would affect all 3 series on Plot1. Therefore, use of this feature is recommended when the plot being modified has the largest number of series.

9.3 Plot Output

Sample Plot output is shown above. The units and data type (e.g. Temp) are determined based on the DataSets for the series on the plot. The legend is shown at the top of the plot. Major and Minor gridlines are also shown on the example plot. For this example, the Last Cycle Definition begins just before 3600 seconds and ends at 6000 seconds. The user has full control over the plot within Excel® and may modify any of the properties associated with the plot or its series after the workbook is created.


10. StripCharts

StripCharts are stacked graphical representations of data as a function of time. Each sub-chart consists of an X-axis, Y-axis, and a collection of up to 3 data series. Up to 6 sub-charts may be displayed on any one StripChart. Additionally, the X-axis may be displayed on each sub-chart or only the bottom chart Each series is represented by one line on the sub-chart, which may have varying Line properties (LineType, Color, Weight) and Marker properties (Symbol, ForeColor, BackColor, Size, Frequency, and Shadow). StripCharts are useful for showing related trends for multiple points with largely varying scales (e.g. Temperature, Heat, Voltage, Current). The StripChart properties form is shown below.

The user may set the number of sub-charts to be displayed on the StripChart. Each series must be assigned to a sub-chart. As nodes are added to a StripChart at the main interface, each node is placed on a separate sub-chart until 6 sub-charts have been added. After this, the next two nodes are added to sub-chart one, the following two are added to sub-chart two and so on. The sub-chart and source DataSet may be assigned at the StripChart properties form or alternatively at the main interface, using the Context Menu on the Nodes in Current Object list box. An option also exists to place the Time axis label on each sub-chart; the default is for only the bottom sub-chart to have the axis label.

10.1 Axis Properties

The axes properties may be defined by the user including axis Maximum and Minimum, and Major and Minor Divisions. The Default Max or Default Min options determine the closest integer multiple of the Major Division for the Minimum and Maximum axes values. By default, both Major and Minor gridlines are displayed, unless the user sets the Major Division equal to the Minor Division. The axis titles and units are based on the source DataSets referenced by the StripChart. If a DataSet is for Temperatures with units of °C, then the axis title reflects this. If two types of units are found on one axis, then both are indicated.

10.2 Series Properties

The user also has control over individual series properties. Three types of series characteristics are available for modification: Data, Line, and Marker. Any changes made in the Series Properties frame are applied to all nodes selected in the Series List, allowing for multiple series to be changed at once. The Data characteristics include the Source DataSet and the axis on which to plot the series. Line characteristics include Line Style, Color, and Weight. The marker characteristics include Symbol, Fore Color, Back Color, Size, Shadow and Frequency. Marker frequency is the only option available through TARP that is not readily changeable in Excel®. This option allows a user to place a marker every so many data points for series that are very dense and would have too many overlapping markers to be able to distinguish the marker symbol. The table below shows the options available for each characteristic.

Style | Color | Weight | Symbol
Solid | Too numerous to list | Hairline | Square
Dashed | 56 Available | Thin | Diamond
Dotted |  | Medium | Triangle
Dash Dot |  | Thick | X 1
Dash Dot Dot |  |  | Star 1
Medium Density 2 |  |  | Dot 1
High Density 2 |  |  | Dash 1
Low Density 2 |  |  | Circle
 |  |  | Plus 1

1 - Indicates “Non Fillable” Marker

2 - Indicates that these options are not available in Excel 2007. Will be automatically converted to Solid if used

Certain options are available to help relate line and marker colors. The first option, Marker has same Fore Color as Line, automatically sets the marker Fore Color when the Line Color is changed. Furthermore, the Marker has same Back Color as Fore Color, sets the marker back color when the fore color is changed. The Set BackColor to None for Non-Fillable Markers option automatically sets the Back Color to None for X, Star, Dot, Dash, and Plus type markers. Lastly, the Apply Size/Freq changes to all Series option applies the Size or Frequency to all series when either of these options is changed.

Similar to axes properties, series properties may also be applied to all other StripCharts to ensure consistency. However, since different plots can have different numbers of series, some care must be taken when using this feature. Assuming that StripChart1 has 3 series and StripChart2 has 7 series, applying series properties while on StripChart1, would only affect the first 3 series on StripChart2. Conversely, applying series properties on StripChart2 would affect all 3 series on StripChart1. Therefore, use of this feature is recommended when the StripChart being modified has the largest number of series.

10.3 StripChart Output

Sample StripChart output is shown to the left. The units and data type (e.g. Temp) are determined based on the DataSets for the series on each sub-chart. The legend is shown at the top of each sub-chart. Major and Minor gridlines are also shown on the time axis, but only Major Gridlines are shown for the Y-Axis. For this example, the Last Cycle Definition begins just before 3600 seconds and ends at 6000 seconds. The user has full control over each sub-chart plot within Excel® and may modify any of the properties associated with the plot or its series after the workbook is created.

Back to Plots | Forward to Tables

Back to Table of Contents


11. Tables

Tables display nodal information at a static point in time. Tables can display Minimum, Average, or Maximum values, Steady-State data or any other timestep, as well as Limits from the specified LimitFile. Each row in the table represents a single node, group, or parameter. Each column in the table shows the values for the display parameter requested by the user. Conditional formatting may be applied to highlight nodes that exceed a limit condition or are within a specified margin of a limit. The user also has a number of formatting options available to control the table display. The Table properties form is shown below.

11.1 Defining the Operation and Source Sheet(s)

To begin, a user selects all the defining characteristics for a column. These include: the operation (e.g. Value, Difference), the source sheet(s), the display parameter(s) to show, and additional information as needed (e.g. Timestep, Limit Name). Four Operations are available: Value, Difference, Min of Sheets, and Max of Sheets. Value is a single datapoint from a single source DataSet. Difference allows a user to display the difference between two timesteps. This may be used to display a maximum change (Max-Min), a margin (Max-Limit), or the change between two orbital points (Timestep 35 – Timestep 21). Min of Sheets and Max of Sheets returns the worst case value from a collection of sheets. This is used to display the maximum value from a selection of multiple cases (i.e. sheets). Once the Operation is selected, certain fields are enabled/disabled. For example, if a Difference operation is selected, then the Sheet 2 and Parameter 2 listboxes are enabled. Next, the user selects the source sheet (or sheets for Min/Max of Sheets) from the Sheet 1 listbox. If a Difference operation is selected, then the user also selects the source sheet for Sheet 2.

11.2 Defining the Display Parameter and adding columns to the Table

After the Operation and Source sheets are defined, the display parameter is selected. Six types of display parameters are available: Min, Avg, Max, SS, Timestep, and Limit. Min, Avg, and Max parameters are only available if the user included these values for the selected source DataSet. The SS display parameter is only available if steady-state output was detected in the selected DataSet. Limits are only available if the user has defined a LimitFile under the AdditionalFiles section at the main interface. For Timesteps and Limits, the user must further select the particular occurrence to tabulate; available Limits or Timesteps are shown in the listbox to the right of the Parameter listbox.

If the display parameter selected is “Timestep”, a list of all output timesteps is shown in the TimeSteps listbox. The user selects a single timestep to display in the resulting table column. If the display parameter is “Limit”, the user then selects the Limit Name from the Limits listbox. Limit Names are defined by the first row in the LimitFile specified by the user. Once all defining characteristics are set, the user then adds a column to the table using the Add to Table button. Alternatively, once all the necessary values are specified, a double click in the Sheet, Parameter, Limit, or Timestep listbox also adds the column to the Table.

If MaxGroup or MinGroup parameters have been defined for any groups included in the Table, Min table entries display the minimum of the MinGroup parameter. Similarly, a Max Table entry displays the maximum of the MaxGroup parameter. This is useful for determining the absolute minimum and/or maximum temperature of all nodes in a group over a period of time. If no MaxGroup or MinGroup parameters are found, then a Max table entry would display the maximum average temperature of all the nodes in the Group and similarly for Min. The sample output below explains this best. The Minimum temperature of Group1 is 1.67 (the minimum average of SUBMODEL.1-3 over the time range 0.0 to 4.0), whereas the minimum of the MinGroup parameter for Group1 is 0.0 (the minimum temperature of SUBMODEL.1-3 over the time range 0.0 to 4.0). Similarly the maximum for Group1 is 3.0, whereas the maximum of the MaxGroup parameter for Group1 is 5.0.

11.3 Table Preview

A table preview is displayed under the Conditional Formatting Options frame. The first column shows the nodes in the table as added at the main interface. Each column added to the table is also displayed. Two fixed rows are reserved to display the Source Sheet and Parameter. In addition, if any limit has been added to the table, three additional fixed rows are reserved to display any applied conditional formatting. The user may delete columns in the table preview by selecting the column to delete and pressing the delete key. The order of the columns may also be adjusted in the table preview by selecting a column and dragging it to its new position using the right mouse button. If the column width is not sufficient to display the properties of a column, the column width can be changed by dragging its right edge. The cursor changes to a left-and-right arrow [image] as the user moves over the column edge with the mouse in the fixed rows portion of the display. When this occurs, the column can be resized. Note that the column size has no effect on the table output. The user may resize columns within Excel® if needed.

11.4 Applying Conditional Formatting

Conditional formatting is available once any limit has been added to the table. If limits are defined in the table, the fields in the Conditional Formatting Options frame are enabled. A maximum of three conditions may be applied. However, if Condition 1 is satisfied, then Conditions 2 and 3 are not evaluated. The same applies for Condition 3 if Condition 2 is satisfied. Therefore, the user should take care and assign conditions in an order consistent with this behavior. Condition 3 can only be defined after Condition 2 is fully defined; Condition 2 can only be defined after Condition 1 has been fully defined.

Each condition consists of 5 basic parts: Condition, LimitName, Margin, Text Color, and Back Color. Condition is one of the following types: >, >=, <=, and <. LimitName is based on the limit selected by the user from the drop-down box. Therefore, the logic for Conditional Formatting is as follows: “IF value [< | <= | >= | >] LimitName ± Margin THEN APPLY Text Color; Back Color”. This may be used to highlight values that have violated a limit. Use of the margin can highlight values that are close to a limit. So, “>=LowLimit+5=3;0” would make the text red (color index 3) and the background the default color (color index 0) for values that were within 5 of the LowLimit. Note, that in general, the three Conditions are intended to be used as follows: Condition 1-Red Limit Violation, Condition 2-Yellow Limit Violation, Condition 3-Within specified Margin of Yellow Limit. Since a red limit is the most severe, values violating Condition 1 would not check Conditions 2 or 3.

11.5 Table Formatting Options

A number of formatting options are available to the user to control the output appearance of the table. The DataFormat may be changed to display more decimal places in the output (up to 6). Both standard numbers (0.0) and scientific notation (0.0E+00) are available. The user is also able to change this on the resulting Excel® worksheet. For tables that span multiple sheets when printing, the user may opt to Repeat Header on Each Page. This displays the first two rows on each printed page. Otherwise, the first two rows are shown only on the first page. The Sheets on Top/Params on Bot is the means by which data is grouped together. One way to group data is to combine identical DataSets (Case 1, Case 2, etc.) with varying display parameters (Min, Max). Conversely, another way is to group identical display parameters (Min, Max) with varying DataSets (Case1, Case 2, etc.). The two table headers below best illustrate the two methods. The user may also Automatically Format Borders, which places thin gridlines around all the data and thick gridlines around sections with common Sheets or Parameters. In the headers below, the top sample would have thick gridlines around Case 1 and Case 2; the bottom sample would have thick gridlines around Min, Avg, and Max. Lastly, the user may make the font bold for values satisfying conditional formats by selecting Conditional Formats are Bold.

Case 1 |  |  | Case 2 |  |  | Min |  | Avg |  | Max
Min | Avg | Max | Min | Avg | Max | Case 1 | Case2 | Case1 | Case2 | Case1 | Case2

Sheets on Top/Params on Bot = True (Left), False (Right)

11.6 Table Output

With Table SubHeadings at left Without Table SubHeadings at Left

Sample Table output is shown above, including Table SubHeadings for Outer and Inner Panels. For this table, no node descriptions were included, Conditional formats are applied to the max column to highlight any violation of the HighLimit by coloring the background in red and the text in white. A second condition is also applied which highlights any values not violating the HighLimit but are within 5 of the HighLimit by making the text red. The two styles of table subheadings are also shown.

If the user selected the Enable Dynamic Columns option under the Preferences form, the resulting table is shifted down by three rows. The first row includes a DynamicSheet label. This allows the user to select the Source DataSet for the column. Once this is selected, the user may then select the DynamicParameter, which is based on all columns on the selected DynamicSheet. These options allow the user to actually change the data that is displayed in the table without having to change the formulas. Note that if the worksheet names for DataSets are changed within Excel®, the validation list for the DynamicSheets drop-down boxes is not automatically updated. Output with Dynmic Columns enabled is shown next.

Dynamic Columns with Descriptions and without Table SubHeadings at Left

Dynamic Columns with Descriptions and with Table SubHeadings at Left


12. Graphical Tables (TARP Pro only)

Graphical Tables display the maximum/minimum temperature predictions as error bars within a bar graph which also highlights up to two sets of limits. Furthermore, a user may add up to 6 user points to indicate other temperatures of relevance (e.g. testing limits, steady state, etc.). The user points may be formatted as desired with numerous symbol, color and size choices. This method of display allows for many nodes or groups to be displayed in a single table without the need for displaying the actual numeric values. If a node has a value that exceeds its limits, then the error bar extends into that portion of the bar graph, clearly showing the violation. The Graphical Table Properties form is shown below.

12.1 Defining Limits and Data

Up to two sets of limits may be defined on the high and low side. The Upper/Lower Outer limits typically represent a red limit (or possibly a survival limit), while the Upper/Lower Inner limits typically represent a yellow (or possibly an operational limit). The available limit names are based on the user specified LimitFile defined in the AdditionalFiles section of the main interface. The Lower and Upper temperature predictions come from the selected sheet(s) in the Lower Temperature and Upper Temperature listboxes. If multiple sheets are selected, then the maximum temperature found for each node/group on the Upper Temperature sheets is reported. Similarly, if multiple sheets are selected for Lower Temperature, then the minimum temperature is selected. The maximum or minimum values may occur on different sheets for different nodes/groups.

If MaxGroup or MinGroup parameters are defined for any groups included in the Graphical Table, a Lower Temperature entry displays the minimum of the MinGroup parameter. Similarly, an Upper Temperature entry displays the maximum of the MaxGroup parameter. This is useful for determining the absolute minimum and/or maximum temperature of all nodes in a group over a period of time. If no MaxGroup or MinGroup parameters are found, then an Upper Temperature entry displays the maximum average temperature of all the nodes in the group, with similar behavior for Lower Temperatures. The table below explains this best.

The Minimum temperature of Group1 is 1.67 (the minimum average of SUBMODEL.1-3 over the time range 0.0 to 4.0), whereas the minimum of the MinGroup parameter for Group1 is 0.0 (the minimum temperature of SUBMODEL.1-3 over the time range 0.0 to 4.0). Similarly the maximum for Group1 is 3.0, whereas the maximum of the MaxGroup parameter for Group1 is 5.0.

12.2 User Points

Up to six user points may be added to any GraphicalTable. These points may represent anything the user desires. Some examples may include what a component was tested to, steady state values, pre and post eclipse points, etc. These points are defined by a DataSet and a timestep (or Minimum, Average, or Maximum). The user may also specify a label to display on the table to identify the purpose of the point. The user may change the symbol, foreground color, background color, size, and shadow of the point. All fields must be specified in order to fully define the point. If any field (excepting the shadow checkbox) is left empty, then the User Point will be ignored.

12.3 Graphical Table Output

Sample Graphical Table output is shown below. The Graphical Table includes two limits (Survival and Operational) and nodal descriptions. The upper limit for HOKIES.1-8 is 40, while the upper limit for HOKIES.101-108 is 35, as shown in the Graphical Table. The Graphical Table also shows a Group, with the displayed values being a MaxGroup and MinGroup parameter evaluation. The error bars on each row represent the maximum and minimum predicted temperatures from the specified DataSet. Lastly, a User Point is added to show the Steady State predictions. Setting Cell A1 to “Descriptions with Values” on the GraphicalTableData worksheet in the created workbook appends the maximum and minimum predict values to the description as shown in the second Graphical Table.

This Graphical Table shows the Descriptions with the Values.


13. RadkManipulations (TARP Pro only)

RadkManipulations allow the user to post process radiation couplings from TSS or RadCad. The general approach is to perform some action(s) on some set(s) of radks and output according to the format specified. The RadkManipulation properties form is shown below.

13.1 File and Action Selection

The user first selects a Radk Input file to be processed. A Radk Output file should also be specified if it is needed. (If only outputting to an Excel sheet or file, the Radk Output file may not need to be specified). Next, the user selecta the action to perform from the following list: Remove Submodel Names, Comment, Delete, Sum, List to a File, List to an Excel Worksheet, Scale, or Renumber. Some actions require further input (e.g. Scale Factor, Worksheet name, etc.), while others need no further information than the action itself. Once an action is selected, the conductor(s) on which to perform that action is selected.

13.2 RadkManipulation Conductor Selection

Three methods exist for specifying the conductors to act upon: All Conductors, Conductors connected to one range of nodes, or conductors between two ranges of nodes. To select all conductors, enter * for both the Node i/j and Node j/i fields. To select a set of conductors connected to a particular range or a specific node, enter the range (e.g. 1-100, MAIN.200-299, SUB.2) into the Node i/j field and * in to the Node j/i field. Lastly to operate on conductors between particular node ranges, enter the two ranges into the Node i/j and Node j/i fields respectively. Note that a range may be only a single node. Once the action and the conductor(s) on which to act have been specified, they are added to the list by clicking the Add button. If the user needs to change something in an existing Action sequence, the radk request may be selected from the list, changed, and then updated by clicking the Modify button. Finally, if the action is no longer needed, it may be removed from the list using the Delete button.

13.3 Generating the Output

Each action and conductor set is processed in the order they were input. Is this manner, a user may first remove the submodel, then comment out all conductors connected to a blocker node, then renumber, and finally scale all conductors connected to a particular node due to an emissivity change. The results of this sequence of actions would be produced in the final output file. The output would be spaced according to the column widths specified by the user under Formatting Options. Furthermore, if varying conductors were output and the Only Output CONDUCTOR DATA option checked, the time varying arrays and VARIABLES1 call statements are be removed. Lastly, the NODE DATA or CONDUCTOR DATA headers may be commented out if desired.


14. RadkCompares (TARP Pro only)

RadkCompares allow the user to compare two output Radk sets from either TSS or RadCad. Couplings must meet a user specified minimum Radk value to be output. Comparable couplings (i.e. between the same pair of nodes) are then output if any of the following exceed the user specified allowable criteria: (1) Maximum Allowable Difference [RadkA – RadkB], (2) Maximum Allowable Percent Difference [(RadkA – RadkB)/RadkA], or (3) Maximum Allowable Difference * Percent Difference [(RadkA – RadkB)2/RadkA]. One of these three methods is also specified as the sort method for the output, with the latter being preferred as it highlights the largest radks with large percentage differences. Furthermore, any couplings found in FileA but not in FileB will be output as well as couplings in FileB but not FileA, so long as they meet the minimum radk value.

14.1 RadkCompare Output

RadkCompare Output is shown below. Radks in FileA only are shown on the left and Radks in FileB only are shown on the right. The differences between the two files are shown below.


15. Backloads and Equivalent Sinks (TARP Pro only)

Backloads and Equivalent Sinks (EqSinks) are methods of representing a complex radiative environment with a simple heat load or radiative coupling and temperature. To generate the Backloads or EqSinks, a subset of nodes (Backload List) for which to calculate the backloads or EqSinks must first be added to the Backload object from the main interface. The backload is computed as the Sj=1:N s(Radkij)Tj4 for each (Node j) which is radiatively coupled to a (Node i) in the Backload List. The Radkij value is retrieved from the input Radk file, and the Tj retrieved from the Temperature file. EqSinks are similar but incorporate the environmental backloading into the equations as well to generate a single temperature and radk to that temperature that would produce an identical heat flow from Node i to the EqSink as in the integrated environment. Both backloads and EqSinks are computed for nodes only and output to the specified file(s) in a format readily usable by thermal solvers. Backloads for groups are the sum of backloads for all nodes in the group, where as EqSinks for groups is the average EqSink Temperatures of all nodes weighted by the Radk value for each node and are shown within the output Excel workbook if the output options are specified. The Backload properties form is shown below.

15.1 Specifying the Backload/EqSink Inputs

First, the temperature offset to absolute zero is specified along with the Stefan-Boltzman constant. These values are based on the output units of the temperature and radk files. The starting numbers for the output arrays, equivalent sink nodes, and couplings to equivalent sinks may also be specified if the default values of 1 are not desired. The Ignore couplings where both nodes are Backload Nodes option allows the user to specify if the backloads/equivalent sinks include or exclude self-view (views of one backload surface to another). Often, nodes that are both part of the same subsystem have their views calculated by the subsystem stand-alone model. Therefore, it is typically desired to exclude the radiative exchange between the surfaces as it is computed by the stand-alone thermal model. The Ignore Couplings where adjoining node is and Use TMM couplings instead for these nodes options are reserved for future features to include interface boundary nodes and couplings and allow for better control of which nodes to include in the backload calculation.

The user must specify, at a minimum, the Radk and Temperature output files as well as their formats. If Heat File 1 and Heat File 2 are also specified, the arrays and steady state values associated with nodes in the Backload list are extracted and included in the output. The base name of the specified Output file is used to generate the .bl and .snk files which contain appropriate TMM syntax for direct use in a thermal model. Lastly, if a Validation file is specified, all individual conductor components used to calculate the backload or equivalent sink are output to a secondary file for further evaluation.

Further options are available that affect the output. Assumption of an imperfect emissivity sink requires a lower temperature than for a perfect emissivity sink. The equation below shows the estimation of the imperfect sink temperature:

(SRadk) *(Ti4 – Tsink4) ≈ (SRadk) *esink * (Ti4 – Timperfect4)

Rearranging yields…

Timperfect ≈ { [Tsink4 + (1-e)*Ti4] / e }1/4

From this equation, the necessary sink temperature for an imperfect sink surface is shown to depend on the temperature of the surface itself. This may also be thought of as having dependence on the heat transferred from the surface, as the two are related. It is also worth noting that a low enough emissivity of the sink surface may result in an inability to maintain the same heat transfer and temperature conditions as the perfect equivalent sink (i.e. a temperature lower than absolute zero would be necessary to accept the amount of heat rejected). For these instances, the temperature is constrained to the lowest allowable value set by the user (or Temp Offset if it is applicable). The user may also opt to constrain the lower temperature, primarily for reasons of testing limitations. For example, a test cryo-panel may need to be -230°C to properly simulate the sink, but only be able to go to -180°C based on liquid nitrogen temperatures.

15.2 Creating and Using the Backload/EqSink Output

To use the backloads with a thermal model, the stand-alone subsystem model is used to generate radiation couplings. These radks include a larger view to space for the subsystem surfaces than the integrated model, therefore, an additional heatload must be added “back” to compensate, hence the term backload. The backloads are then included along with these radks to run the thermal model. This is the same method used by most thermal radiation codes to calculate the environmental loading.

To output the data in a format for further manipulation or plotting, use the Output Backload / Equivalent Sink to Excel options. This creates internal DataSets which generate worksheets in the output workbook with the Equivalent Sink temperatures and/or Backloads. These values may then be combined, manipulated, or plotted within Excel®.

Combining backloads is a simple summation. However, this is, in effect, averaging out local heat sources. If a large, subdivided panel had a few locations with high backloads and many locations with low backloads, the overall sum of backloads over the entire panel would show a relatively low backloading. Since the backload term already includes the area and emissivity, removing these terms provides the incident flux from backloading surfaces, which may be a better term to average and then apply to the composite receiving surface. (i.e. average based on an incident backload flux rather than a pure backload).

To combine nodal equivalent sinks to estimate a group equivalent sink for multiple nodes/surfaces, it is recommended to use a T4 weighted average of the output nodes based on the Radk sum. {S(Radki*Ti4) / SRadki} This value can be extracted from the output equivalent sink file. Therefore, higher emissivity and larger area surfaces would be weighted higher than lower emissivity and smaller area surfaces for a composite equivalent sink. This is the default technique used by TARP when calculating the EqSink for a group. The user may override this and use a simple weighted average based on Radk values. {S(Radki*Ti) / SRadki}

15.3 Backload/EqSink Calculations and Derivation

Starting with the basic energy balance equation for node i in the node range (1:N)…

(i) mCp dT/dt = Qin – Qout + Qdissipation + Qenv,radiative

Qin and Qout can be further divided into Qin,linear, Qout,linear, and Qin,radiative, Qout,radiative yielding…

(ii) mCp dT/dt = (Qin,linear – Qout,linear) + (Qin,radiative – Qout,radiative) + Qdissipation + Qenv,radiative

Extracting and expanding (Qin,radiative – Qout,radiative) yields…

(iii) (Qin,radiative – Qout,radiative) = sSj=1,N Radkij (Tj4 – Ti4)

(Qin,radiative – Qout,radiative) = sSj=1,N Radkij (Tj4) – {s (Ti4) Sj=1,N Radkij}

Assuming that sSj=1,N Radkij ≈ s Areai e i (SFij=1) and QBL,radiative = sSj=1,N Radkij (Tj4) yields…

(iv) mCp dT/dt = (Qin,linear – Qout,linear) + Qdissipation + Qenv,radiative + QBL,radiative – s Areai*ei (Ti4)

As seen in equation (iii), the radiative heat transfer now only depends on the area, emissivity, and temperature of Node i and the Backload (QBL,radiative). This may be further rearranged to find the equivalent sink temperature where…

(v) Qenv,radiative + QBL,radiative –s Areai ei (Ti4) =s Areai ei (Tsink4 – Ti4)

The equivalent sink temperature is then found to be…

(vi) Tsink = { (Qenv,radiative + QBL,radiative) / (s Areai ei ) }¼

These equations are all derived assuming that the entire field of view of node i is replaced with either a Backload or an Equivalent Sink. If only a partial field of view is to be replaced, a similar derivation can be made. This may be desirable when node j’s in the field of view of node i are also included in the subsystem (e.g. 2 panels on an instrument). For this case, starting again the basic energy balance equation for node i, where the node range (1:n) includes all nodes in the Backload List, and (n+1:N) includes all nodes not in the Backload List…

(vii) DQradiative = sSj=1,n Radkij (Tj4 – Ti4) + sSj=n+1,N Radkij (Tj4 – Ti4)

DQradiative = sSj=1,n Radkij (Tj4) + sSj=n+1,N Radkij (Tj4) –s (Ti4 ){Sj=1,n Radkij +Sj=n+1,N Radkij }

QBL,radiative is now defined as sSj=n+1,N Radkij (Tj4) yielding…

(viii) DQradiative = sSj=1,n Radkij (Tj4) + QBL,radiative – s (Ti4){ Sj=1,n Radkij + Sj=n+1,N Radkij }

Further examination shows that the first and third terms are computed by the radiation model containing only nodes in the Backload List (e.g. instrument, subsystem). The fourth term [s(Ti4)Sj=n+1,N Radkij ] is also approximated with the stand alone model as a larger view to space, where previously nodes in the (n+1:N) range had been.


16. HeatMaps

HeatMaps are the most powerful feature available in TARP. HeatMaps are specialized workbooks with embedded VBA macros for computing and displaying heat flows within a model. Therefore, it is necessary to enable macros in Excel®. If macros have been automatically disabled, they may be enabled under Tools-Macro-Security in Excel® with the Medium security option. A HeatMap workbook is capable of displaying heat flow between two nodes, between two groups, from a group to nodes, and from a node to groups. With 3 levels of grouping plus an additional DynamicGroup option, a variety of heat flow paths may easily be investigated. A sample workbook for a node-to-group HeatMap is shown below.

Node-to-Group HeatMap

16.1 Creating the HeatMap

To create a HeatMap workbook, the HeatMap option is first selected under WorkBook Properties at the Main Interface. For TARP Pro users, a prompt is displayed to create DataSets or Binary HeatMap Files. For TARP users, only the DataSet option is available and no prompt is issued. For DataSets, three DatsSets are automatically created: Temp (Temperatures), Heat (Heat Loads), and Cond (Conductances). Therefore, each output timestep must include Temperatures, Heat Loads, and Conductances. Failure to do this may result in Temperatures from one timestep being used with Heat Loads from another, since HeatMaps assume that each column on the three DataSet sheets represents the same timestep. If too many data point are encountered (in particular for the conductances), the additional data “spills over” onto sequentially numbered sheets (e.g. Cond2, Cond3, etc.). While there is no technical limit on the number of sheets, a very large workbook may fail to open on a user’s system. The size of a workbook that can be opened is dictated by a number of factors, including available memory.

Enabling a HeatMap also enables the Include Node Descriptions option, and therefore requires the InputFile (for SINDA and TAK outputs) to be specified. This InputFile is used to extract the node pairs for each conductor number. For ESABLK outputs, the node pairs and descriptions are included in the output file; therefore, it is not required. The node pairs and conductor numbers are written to the Lin and Rad sheets for linear conductors and radiative conductors respectively. For SINDA models, the HeatMaps do not make any associations between which submodels are built and which are not. Therefore, errors may occur if the user does not build all the submodels, since a conductor may exist on the Lin/Rad sheets but not on the Cond sheets. If this is the case, the user is advised to manually remove the conductors not built in the solution from the Lin/Rad sheets and select ReCalculateAll from the TARP menu.

16.2 Controlling the HeatMap Output

All cells requiring input from the user are highlighted in red. When the workbook is initially opened, default values for Sigma and Toffset are entered. The user first sets these to the appropriate values for their model. Next, the user selects the timestep of interest in the Time drop-down box. At this point, macros begin calculating the heat flow through each conductor and store the group-to-group and node-to-group heat flow components. When a value is specified for Node i, all values connected to it are displayed. Node i may be a group or a node; specifying a group results in Group-to-___ heat flows, while specifying a node results in Node-to-___ heat flows. Similarly, the Heat To field may be changed to Node, MajorGroup, MinorGroup, SubGroup, or DynGroup. Setting the Heat to field to node results in ___-to-Node heat flows, etc. Therefore, the user has a number of options available for displaying heat flows based on the Node i and Heat to values. For example, if a group is specified as Node i and the Heat to is set to MinorGroup, then the heat flows displayed are Group-to-Group at the MinorGroup level. Any nodes not included in a group are displayed in the MISC group by default. This preserves energy balances throughout the model. Double clicking a Node j value replaces Node i with the Node j value selected and outputs the new HeatMap.

The output data displayed includes the node j description, node/group j, conductor type, conductance value, temperature of node/group j, and heat flow to each node/group j connected to node/group i. All linear conductors are grouped together as are all radiative conductors. The left hand side sorts the data from the largest quantity of heat leaving node/group i (negative heat) to the largest amount of heat entering node/group i (positive). The right hand side reverses this order. The user may control how many decimal places are shown for temperature and heat flow using the formats available in the Format field. Furthermore, the user may opt to only display heat flows above the cutoff specified in Min Heat. In the top right, a summary table is displayed, which includes the heat in and out by conduction and radiation, as well as the heat applied to node/group i. The sum in and sum out are also displayed, giving an idea of how balanced node/group i is. These values are based on the displayed values, so if the user has entered a Min Heat greater than 0.0, some energy is not be included in these sums. Note that energy storage/release is not included, as the difference between output timesteps is generally much larger than the calculation timesteps used and may not be a good indicator of instantaneous energy storage/release.

Node-to-Node HeatMap

Group-to-Node HeatMap

Group-to-Group HeatMap

16.3 Dynamic Groups

The DynamicGroups option allows a user to expand some groups to detailed levels, while leaving other groups collapsed to simplistic representations. This is useful for investigating detailed heat flows in a specific portion of the model, without the need for detail throughout the remainder of the model. To change the DynamicGroups setting, the user double clicks the DynGroup cell on the NodeInfo sheet or selects Update Groups from the TARP menu. A group tree is shown similar to the one below. Only groups shown in the tree are considered “active”. For the case below, the Panels MajorGroup is expanded to include the Inner and Outer Minor groups, the Elec MajorGroup is expanded to include the Lower, Mid, and Upper MinorGroups, but the Battery group is collapsed to a single MajorGroup, even though it does have child groups defined under it. After the user closes the Dynamic Groups form, the heat flows are recalculated based on the new group definitions and the HeatMap is re-output.

16.4 Group to Group Heat Flow Matrix

An option exists to display heat flows between groups in a matrix format by selecting Make Heatflow Matrix from the TARP menu in the Excel® workbook. This option creates four worksheets: MajorGroup, MinorGroup, SubGroup, and DynGroup based on the current timestep, Stefan-Boltzmann constant, and offset to absolute temperature. If any of these values are changed, the data must be regenerated, overwriting the existing sheets. Once the data is generated, the user may display: Tot Heat, Lin Heat, Rad Heat, Lin Cond, or Rad Cond by selecting the desired option from the drop down list in Cell A1 on each sheet. The average temperature of the group, source heat, and heat imbalance are also displayed, but may only be relevant when displaying total heat flows. A comment is added to each cell in the matrix which displays the Total Heat, Linear Heat, Radiative Heat, Linear Conductance, and Radiative Conductance. For Compare HeatMaps, the results for Model B are shown below the results for Model A. This may be useful for comparing the heatflows between groups at different timesteps or under different conditions. No more than 253 groups may be displayed in this format.

MajorGroup Matrix showing Total Heat

MajorGroup Matrix showing Linear Heat

MinorGroup Matrix showing Total Heat with comment displayed

16.5 Transient HeatMaps

Selecting Make Transient HeatFlows from the TARP menu displays a form allowing the user to specify nodes or groups for which to output transient heat flows. Nodes/Groups may be selected for output by either double clicking them in the Available Nodes/Groups listbox or selecting them and moving them to the Output Nodes/Groups listbox using the right arrow button (-->). Nodes/group may be removed from the output by selecting the node and pressing the delete key or using the left arrow button (<--). By default, the HeatTo selection is automatically set to the appropriate group level (Major, Minor, Sub) where the Output Node/Group first appears. If a node is selected, then the HeatTo selection is set to Node. To change the default value, double click on the corresponding row in the Heat To listbox to toggle through MajorGroup, MinorGroup, SubGroup, DynGroup, and Node options. Once all desired nodes/groups have been added, and the HeatTo fields defined, click the Make Transients… button. The workbook calculates the heatflows at each timestep and outputs the corresponding connections to a worksheet with the same name as the Node/Group.

After all timesteps have been computed, the zero-heatflow entries are removed and the worksheet is formatted. A summary table is shown at the top highlighting the Temperature of the requested Node/Group, Linear Heat In and Out, Radiative Heat In and Out, Applied Source, and the Imbalance. Changing the What to Show cell (B5) on the corresponding worksheet allows the user to display the heat flow to/from, conductance to, or temperature of each adjoining Node/Group. Sample output is shown next.

Transient Heatflows for Groups connected to OUTERTOP

Transient Temperatures for Groups connected to OUTERTOP

Transient Conductances for Nodes connected to HOKIES.101

16.6 Compare HeatMaps

The CompareHeatMaps option allows the user to specify two separate models for the generation of HeatMaps: Model A and Model B. Using the Map2 worksheet, results from two models can be displayed side by side. This may also be used to display different Node i or Timestep values for a single model HeatMap. Each side has independent controls for Sigma, Toffset, Format, Min Heat, and Heat To parameters and heat balance summaries.

To compare differences between heat flows the user may turn on the Compare option in cell F4. This signals to the heatmap to sequence the two sides. When either Node i is changed in this mode, the Node i for the opposite model is also updated. The data is output and sequenced with each line containing heat paths of the same type (Lin, Rad), Node, and Conductance. In cases where a conductor may exist in one model but not in the other, the output attempts to synchronize the two sets of outputs matching the closest conductance value found for the same node and conductor type. If no match can be made, then a blank line is output where the heat path is missing from the other model. This is useful when comparing two models that do not include the exact same environments (e.g. flight vs. test).

Different Nodes (HOKIES.102 and HOKIES.2), Different Timesteps, Compare Off

Same node (HOKIES.2), Different Timesteps, Compare On

One Node/One Group (HOKIES.2, INNER), Different Timesteps, Compare Off


17. Binary HeatMap Files (TARP Pro only)

Binary Heatmap files move the necessary heatmap data (Temperatures, Heat Loads, Conductances, and Conductor Node pairs) into an external binary file. This file is then read by the HeatMap workbook and the data is loaded from the file and processed internally. The advantage of this approach is that much larger models may be loaded in a much shorter time than if the data is stored on worksheets. See the HeatMaps section for a full description of the HeatMap capabilities. The Properties form for a Binary Heatmap File is shown below:

17.1 Creating the Binary HeatMap File Object

Binary HeatMap Files objects may be created in one of two ways. First, if a TARP Pro user checks the HeatMap (or CompareHeatMap) option under Workbook Properties, they are prompted to either create Binary HeatMap Files or the three (or six) corresponding DataSets (Temp, Heat, Cond). If Binary HeatMap File is selected, a new object is created under the Binary HeatMaps branch of the TARP Objects Tree. The name of the ExcelOutputFile is automatically set to the same nams as the Output Filename for the first Binary HeatMap object. Alternately, a user may create Binary Heatmap file objects manually, but they may not necessarily be linked to the output workbook, depending on the name of the ExcelOutputFile.

17.2 Entering Files

Binary HeatMap Files require the same output as HeatMaps using DataSets, namely Temperature, Heat Load, and Conductor output at each timestep. In addition, the Binary HeatMap object also requires the input file and its format. Once specified, a binary formatted file (.bhf) file is output which may be linked to the Excel workbook by its filename. Upon opening a HeatMap workbook, the current directory is checked to see if a .bhf file is found with the same basename. If files with the same basename and an A.bhf and B.bhf appended are found, then the workbook is assumed to be a Compare Heatmap and both files are loaded. If all three files exist, the user is prompted to select either a single HeatMap mode or a Compare HeatMap mode. For example, a workbook named Test_HeatMap.xls would search for a Test_HeatMap.bhf file to retrieve data. If it finds instead Test_HeatMapA.bhf and Test_HeatMapB.bhf, the workbook loads both files and assume a Compare Heatmap is desired. If the name of the Excel workbook or binary heatmap file is changed in Windows, then the corresponding filename of the other file(s) must also be changed to retain the connection. This allows a user to create only binary heatmap files without a corresponding workbook and then access them via a previously created Excel workbook. For example, a user may first create a heatmap workbook called Case1. Then a Binary Heat Map file could be created called Case2; changing the Case1.xls to Case2.xls would now access the Case2.bhf data.

17.3 Adding Nodes for Sub-Network Output

An option exists to allow the user to add nodes or groups to the Binary HeatMap file. If nodes are added, then only couplings to these nodes are included in the Binary HeatMap file. This allows for a much smaller network in very large models, but is also a bit less useful for tracing heat flows. If a group is added, then the nodes contained in that group (or any children of that group) are internally added before beginning the trace procedure. The user may opt to trace to additional depth layers, up to 5 levels deep. To clarify, suppose nodes 1-10 are added to a Binary HeatMap. Tracing one level may find that nodes 1-50 are all coupled to nodes 1-10. Tracing another level may show that nodes 1-150 and a Space Node are all coupled to 1-50. Tracing yet another level may show that nodes 1-10000 are coupled to nodes 1-150 and the Space Node. At this point, the couplings from numerous other locations to space are likely not relevant to the heat flows of the original nodes 1-10. Therefore, it is recommended to terminate any traces when they reach a boundary node. Some common node identifiers are provided, but the user should specify them explicitly if necessary.

17.4 Internal Storage in HeatMap Workbook

For models with less than 1.5 million conductors, the entire thermal network is loaded and stored in memory, including: all individual heat flow paths, Group to Group, Node to Group, and Group to Node heat flow matrices. For very large models (more than 1.5 million conductors), only the Group to Group, Node to Group, and Group to Node heat flow matrices are stored internally. When a user specifies a node on the Map1 sheet, the bhf file is processed and a subset of conductors is identified that is connected to the specified node. These couplings are then processed to determine the heat flow to and from the specified node. While this approach may have some degradation in performance, it does allow for much larger models to be processed at the nodal level without exceeding memory limitations. The threshold for what is considered a large model may be changed by the user by selecting Set Large Model Threshold under the TARP menu in the resulting workbook. Note that this value is not preserved when saving the workbook and would need to be reset if a new Excel® session is started.

To see basic statistics from the binary heatmap file within the workbook, select the Show Binary Data Statistics option from the TARP menu in Excel. A message box similar to the one show to the left will be displayed listing the number of nodes and timesteps found in each binady heatmap file in use. Note that if all submodels are built for SINDA85 output, then the number of Conds in the Conductor output and Conductor Input should match. Also, for SINDA85, the number of Nodes in the Temperature Output and Heat Output should also match. For SINDA/G, the number of Nodes in the Temperature output is typically smaller than the number of Nodes in the Heat output, since Heat values are not output for boundary nodes. Lastly, if only one output timestep is found for the conductor data, a warning message (shown below) will be displayed indicating that the first timestep (Index 0) will be used for determining the conductor values. This is acceptable so long as the model contains only constant conductors of the variance of the conductors is negligible.

The performance improvement of using a binary heatmap file instead of storing the data on worksheets in the output workbook is approximately 10:1. A model with about 1800 nodes and 94,500 conductors took 9:38 minutes to load the data, evaluate the heat flows and output the worksheet with the data stored on worksheets; the same model took 1:00 minute with the data stored in a Binary HeatMap File. For larger models, the performance improvement should be greater, since a significant amount of time is spent retrieving the conductance values, which is much faster with the binary format.


18. Session Files

Session files are a means to save and recall properties of a TARP session. This saves the user time if the same objects are to be re-created with only a few modifications. The formats for each object are shown below. In general, each object begins with a [Section] and ends with a blank line. Any object properties not specified are set to their default values; as such, only portions of the object need to be defined.

18.1 Session File Data Types

Generic data types are listed below. Object types specific to particular objects are specified in the section for that object.

{Boolean} either True or False should be specified

{File Path} the full path including drive letter must be specified (spaces are allowed)

{XXX|YYY|ZZZ} one of XXX, YYY, OR ZZZ are allowed as inputs (single)

{XXX,YYY,ZZZ} any of XXX, YYY, OR ZZZ are allowed as inputs (multiple)

{Valid String} a sequence of alpha-numeric characters

{Valid Integer} a numeric entry with no decimal point (e.g.15)

{Valid Float} a numeric entry with a decimal point (e.g.15.0)

{Valid Sheet} a {Valid String} that does not contain / \ [ ] ? or *

{Valid Range} Comma separated list of nodes and ranges (e.g. SUB1.5,SUB2.5-10) or * for all nodes

18.2 WorkBook Properties

Only one WorkBook Properties block may exist in a session and is defined as follows:

[WorkBook Properties]

  IncDesc = {Boolean}

  HeatMap = {Boolean}

  CompareHeatMap = {Boolean}

  UpdateExisting = {Boolean}

18.3 Additional Files

Only one Additional Files block may exist in a session and is defined as follows:

[Additional Files]

  InputFile = {File Path}

  InputFileA = {File Path}

  InputFileB = {File Path}

  LimitFile = {File Path}

  WeightingFile = {File Path}

  UnitConversionFile = {File Path}

  ExcelOutputFile = {File Path}

The InputFileA and InputFileB options would appear for a CompareHeatMap only. All other instances of an input file would be InputFile.

18.4 DataSet

Numerous DataSet blocks may exist in a session file, each defined as follows:

[DataSet]

  File = {File Path}

  Format = {SINDA85|SINDA/G|ESABLK|ESATBL|TMG|TAK|TSS|DESKTOP|CSV|SPACE|TAB}

  Parameter = {T|Q|G|C|Q”|QA|QA|QE|QI|QR|GL|GR}

  SheetName = {Valid Sheet}

  Convert Time From = {Valid Integer}

  Convert Time To = {Valid Integer}

  Convert Param1 From = {Valid Integer}

  Convert Param1 To = {Valid Integer}

  Convert Param2 From = {Valid Integer or -1}

  Convert Param2 To = {Valid Integer or -1}

  Transpose = {Boolean}

  Filter = {Boolean}

  FilterCriteria = {Valid Range} or blank

  ReferencedNodes = {Boolean}

  IncludeMin = {Boolean}

  IncludeAvg = {Boolean}

  IncludeMax = {Boolean}

  IncludeTimeMin = {Boolean}

  IncludeTimeMax = {Boolean}

  IncludeDelta = {Boolean}

  SS Timestep Index = {Valid Index or -1}

  TR Timestep Start Index = {Valid Index or -1}

  TR Timestep End Index = {Valid Index or -1}

  Output Timesteps = {Timestep Output}

DataSet Data Types:

{Valid Criteria} a special version of {Valid String} based on the rules for node filtering

{Valid Index} a special version of {Valid Integer} that requires an index to a particular array (e.g. timesteps)

{Timestep Output} a string listing of T or F indicating for each timestep if it is to be output. (e.g. TTFFTTFT would output timesteps 1,2,5, 6, and 8). Alternately, the keyword ALL may be used to specify that all timesteps should be output. Lastly, a (X,Y) format such as (1,1) would specify to output 1 timestep, skip one timestep and repeat this pattern until the last timestep is reached. A user is cautioned that changing filenames without updating the Timestep Indexes or Output Timestep may result in unexpected behavior. When in doubt, make the fields blank and TARP selects the defaults, which may then be changed through the interface.

18.5 Group

Numerous Group blocks may exist in a session file., each defined as follows:

[Group]

  GroupName= {Group Name}

  ParentName= {Group Name}

  Filter= {Valid Range}

  Nodes= {Node1},{Node2},{Node3},...,{NodeN}

Group Data Types:

{Group Name} a {Valid String} that does not contain any comma characters (,)

{Node#} valid Node on DataSet sheets

18.6 Parameter

Numerous Parameter blocks may exist in a session file, each defined as follows:

[Parameter]

  ParameterName= {Valid String}

  ParameterType= {MaxNodes|MinNodes|MaxGroup|MinGroup|Difference}

  Nodes= {Node1},{Node2},{Node3},...,{NodeN}

18.7 Plot

Numerous Plot blocks may exist in a session file, each defined as follows:

[Plot]

  Title={Valid String}

  SheetName={Valid Sheet}

  X Axis={Axis String}

  Y Axis Pri={Axis String}

  Y Axis Sec={Axis String}

  Series={SheetName}/{Data}/{Pri|Sec}

    Line={Color},{LineType},{Weight}

    Marker={Symbol},{Color},{Color},{Size},{Freq},{Shadow|NoShadow}

...

  Series={SheetName},{Data},{Pri|Sec}

    L1ine={Color},{LineType},{Weight}

    Marker={Symbol},{Color},{Color},{Size},{Freq},{Shadow|NoShadow}

** Note that the Series are delimited by “/”. This is to allow a comma in a SheetName which would be interpreted as a delimiter if a “,” were used instead of a “/”.

Plot Data Types:

{Axis String} AxisMin or -100000 for Default, AxisMax or 100000 for Default, MajorDivision, MinorDivision (e.g. -100000,100000,5,1)

{SheetName} String value representing a valid DataSet

{Data} String value representing a valid Node or Group in the {SheetName} DataSet

{Size} Integer value for marker size

{Freq} Integer value for marker frequency

{LineType} any entry in the table below

Solid | Dashed | Dotted | Dash-Dot | Dash-Dot-Dot | Med Density
High Density | Low Density |  |  |  |

{Color} any entry in the table below

Default | None | Black | White | Red | DarkRed
Blue | DarkBlue | LightBlue | BlueGray | OceanBlue | SkyBlue
Yellow | DarkYellow | LightYellow | Gold | PaleBlue | IceBlue
Green | DarkGreen | LightGreen | BrightGreen | OliveGreen | SeaGreen
Turquoise | LightTurquoise | Aqua | Violet | DarkPurple | Lime
Teal | DarkTeal | Indigo | Periwinkle | Rose | Lavender
Orange | LightOrange | Brown | Tan | Coral | Pink
Gray25 | Gray40 | Gray50 | Ivory | Plum |

{Weight} any entry in the table below

Hairline

Thin

Medium

Thick

{Symbol} any entry in the table below

None | Square | Diamond | Triangle | X | Star
Dot | Dash | Circle | Plus |  |

18.8 StripChart

Numerous StripChart blocks may exist in a session file, each defined as follows:

[StripChart]

  Title={Valid String}

  SheetName={Valid Sheet}

  NoCharts={Valid Integer}

  X Axis={Axis String}

  Series={SheetName}/{Data}/{ChartNo}

    Line={Color},{LineType},{Weight}

    Marker={Symbol},{Color},{Color},{Size},{Freq},{Shadow|NoShadow}

...

  Series={SheetName},{Data},{ChartNo}

    Line={Color},{LineType},{Weight}

    Marker={Symbol},{Color},{Color},{Size},{Freq},{Shadow|NoShadow}

** Note that the Series are delimited by “/”. This is to allow a comma in a SheetName which would be interpreted as a delimiter if a “,” were used instead of a “/”.

StripChart Data Types:

{Axis String} AxisMin or -100000 for Default, AxisMax or 100000 for Default, MajorDivision, MinorDivision (e.g. -100000,100000,5,1)

{SheetName} String value representing a valid DataSet

{Data} String value representing a valid Node or Group in the {SheetName} DataSet

{ChartNo} Integer value for Chart Number Index

{Size} Integer value for marker size

{Freq} Integer value for marker frequency

{LineType} any entry in the table below

Solid | Dashed | Dotted | Dash-Dot | Dash-Dot-Dot | Med Density
High Density | Low Density |  |  |  |

{Color} any entry in the table below

Default | None | Black | White | Red | DarkRed
Blue | DarkBlue | LightBlue | BlueGray | OceanBlue | SkyBlue
Yellow | DarkYellow | LightYellow | Gold | PaleBlue | IceBlue
Green | DarkGreen | LightGreen | BrightGreen | OliveGreen | SeaGreen
Turquoise | LightTurquoise | Aqua | Violet | DarkPurple | Lime
Teal | DarkTeal | Indigo | Periwinkle | Rose | Lavender
Orange | LightOrange | Brown | Tan | Coral | Pink
Gray25 | Gray40 | Gray50 | Ivory | Plum |

{Weight} any entry in the table below

Hairline

Thin

Medium

Thick

{Symbol} any entry in the table below

None | Square | Diamond | Triangle | X | Star
Dot | Dash | Circle | Plus |  |

18.9 Table

Numerous Table blocks may exist in a session file, each defined as follows:

[Table]

  SheetName= {Valid Sheet}

  Nodes= {Data1},{Data2},{Data3},...,{DataN}

  SourceSheet= {SheetName1}/{SheetName2}/.../{SheetNameM}

  Parameter= {Parameter1},{Parameter2},...,{ParameterM}

  Conditional 1= {Condition1},{Condition2},...,{ConditionM}

  Conditional 2= {Condition1},{Condition2},...,{ConditionM}

  Conditional 3= {Condition1},{Condition2},...,{ConditionM}

  Options= {BoldConditionals,SheetsOnTop,FormatBorders,RepeatHeaders, GroupSubHeadingsAtLeft}

** Note that the sheet names are delimited by “/”. This is to allow a comma in a SheetName which would be interpreted as a delimiter if a “,” were used instead of a “/”.

Table Data Types:

{SheetName#} the sheet name for a particular DataSet

{Data#} valid Node or Group from a DataSet

{Parameter#} Table parameter (e.g. Min, Max, etc.)

{Condition#} {<|<=|>=|>}LimitName+{Margin}={ForeColorIndex},{BackColorIndex} or leave blank (see Conditional Formatting section)

{ColorIndex} any numeric entry in the table below

1 | Black | 2 | White | 3 | Red | 4 | BrightGreen | 5 | Blue
6 | Yellow | 7 | Pink | 8 | Turquoise | 9 | DarkRed | 10 | Green
11 | DarkBlue | 12 | DarkYellow | 13 | Violet | 14 | Teal | 15 | Gray25
16 | Gray50 | 17 | Periwinkle | 18 | Plum | 19 | Ivory | 20 | LightTurquoise
21 | DarkPurple | 22 | Coral | 23 | OceanBlue | 24 | IceBlue | 25 | DarkBlue
26 | Pink | 27 | Yellow | 28 | Turquoise | 29 | Violet | 30 | DarkRed
31 | Teal | 32 | Blue | 33 | SkyBlue | 34 | LightTurquoise | 35 | LightGreen
36 | LightYellow | 37 | PaleBlue | 38 | Rose | 39 | Lavender | 40 | Tan
41 | LightBlue | 42 | Aqua | 43 | Lime | 44 | Gold | 45 | LightOrange
46 | Orange | 47 | BlueGray | 48 | Gray40 | 49 | DarkTeal | 50 | SeaGreen
51 | DarkGreen | 52 | OliveGreen | 53 | Brown | 54 | Plum | 55 | Indigo
56 | DarkBlue |  |  |  |  |  |  |  |

18.10 GraphicalTable

Numerous Table blocks may exist in a session file, each defined as follows:

[GraphicalTable]

  SheetName= {Valid Sheet}

  Title= {Valid String}

  NodeNos= {Data1},{Data2},{Data3},...,{DataN}

  LowerOuterLimit= {ValidLimit}

  LowerInnerLimit= {ValidLimit}

  MinSheet(s)= {SheetName1}/{SheetName2}/.../(SheetNameN}

  MaxSheet(s)= {SheetName1}/{SheetName2}/.../(SheetNameN}

  UpperInnerLimit= {ValidLimit}

  UpperOuterLimit= {ValidLimit}

  ErrorBar={Color},{LineType},{Weight}

  UserPoint1={Valid Sheet}/{Max|Avg|Min|TS(Index)}/{Valid String}

    Marker={Symbol},{Color},{Color},{Size},{Shadow|NoShadow}

  UserPoint2={Valid Sheet}/{Max|Avg|Min|TS(Index)}/{Valid String}

    Marker={Symbol},{Color},{Color},{Size},{Shadow|NoShadow}

  UserPoint3={Valid Sheet}/{Max|Avg|Min|TS(Index)}/{Valid String}

    Marker={Symbol},{Color},{Color},{Size},{Shadow|NoShadow}

  UserPoint4={Valid Sheet}/{Max|Avg|Min|TS(Index)}/{Valid String}

    Marker={Symbol},{Color},{Color},{Size},{Shadow|NoShadow}

  UserPoint5={Valid Sheet}/{Max|Avg|Min|TS(Index)}/{Valid String}

    Marker={Symbol},{Color},{Color},{Size},{Shadow|NoShadow}

  UserPoint6={Valid Sheet}/{Max|Avg|Min|TS(Index)}/{Valid String}

    Marker={Symbol},{Color},{Color},{Size},{Shadow|NoShadow}

** Note that the sheet names are delimited by “/”. This is to allow a comma in a SheetName which would be interpreted as a delimiter if a “,” were used instead of a “/”.

GraphicalTable Data Types:

{Data#} valid Node or Group from a DataSet

{SheetName#} the sheet name for a particular DataSet

{Valid Limit} valid limit name from Limit File

{TS(Index) Timestep indicator and zero-based timestep array index

{LineType} any entry in the table below

Solid | Dashed | Dotted | Dash-Dot | Dash-Dot-Dot | Med Density
High Density | Low Density |  |  |  |

{Color} any entry in the table below

Default | None | Black | White | Red | DarkRed
Blue | DarkBlue | LightBlue | BlueGray | OceanBlue | SkyBlue
Yellow | DarkYellow | LightYellow | Gold | PaleBlue | IceBlue
Green | DarkGreen | LightGreen | BrightGreen | OliveGreen | SeaGreen
Turquoise | LightTurquoise | Aqua | Violet | DarkPurple | Lime
Teal | DarkTeal | Indigo | Periwinkle | Rose | Lavender
Orange | LightOrange | Brown | Tan | Coral | Pink
Gray25 | Gray40 | Gray50 | Ivory | Plum |

{Weight} any entry in the table below

Hairline

Thin

Medium

Thick

18.11 RadkManipulation

Numerous RadkManipulation blocks may exist in a session file, each defined as follows:

[RadkManipulation]

  ObjectName= {Valid String}

  InputRadkFile= {File Path}

  OutputRadkFile= {File Path}

  Action= {Valid Radk Action}

  ...

  Action= {Valid Radk Action}

  CondNoWidth= {Valid Integer}

  NodeIWidth= {Valid Integer}

  NoedJWidth= {Valid Integer}

  CondValWidth= {Valid Integer}

  OutputOnlyConductorData= {Boolean}

  CommentNodeHeader= {Boolean}

  CommentCondHeader= {Boolean}

RadkManipulation Data Types:

{Valid Radk Action} string that consists of: {RadkActionStr} for conductors with NodeI/J= {Valid Range} and Node J/I = {Valid Range}

{RadkActionStr} REMOVE SUBMODEL | COMMENT OUT | DELETE | SUM |

LIST TO FILE {File Path} | LIST TO EXCEL {Valid Sheet}

RENUMBER STARTING WITH {Valid Integer} | SCALE BY {Valid Float}

18.12 RadkCompare

Numerous RadkCompare blocks may exist in a session file, each defined as follows:

[RadkCompare]

  SheetName= {Valid Sheet}

  RadkFilenameA= {File Path}

  RadkFilenameB= {File Path}

  MinimumRadk= {Valid Float}

  AllowableDelta= {Valid Float}

  AllowablePercentDelta= {Valid Float}

  AllowableDeltaTimePercentDelta= {Valid Float}

  SortBy={1 for sort by Allowable Delta

          2 for sort by Allowable Percent Difference

          3 for sort by Allowable Delta * Allowable Percent Delta}

18.13 Backload

Numerous Backload blocks may exist in a session file, each defined as follows:

[Backload]

  SheetName= {Valid Sheet}

  BLNodes= {Node1},{Node2},{Node3},...,{NodeN}

  TempOffset= {Valid Float}

  StefanBoltzman= {Valid Float}

  StartingArrayNo= {Valid Integer}

  StartingCondNo= {Valid Integer}

  StartingNodeNo= {Valid Integer}

  DegradedEmissivity= {Valid Float}

  LowerTemperatureConstraint= {Valid Float}

  IgnoreNodes= {Valid Range}

  UseTMMNodes= {Valid Range}

  IgnoreSelfView= {Boolean}

  RadkFilename= {File Path}

  RadkFormat= {TSS|Desktop|Esarad}

  TempFilename= {File Path}

  TempFormat= {SINDA85|SINDA/G|ESABLK|ESATBL|TAK2000|TMG}

  HeatRateFilename1= {File Path}

  HeatRateFormat1= {TSS|Desktop|Esarad}

  HeatRateFilename2= {File Path}

  HeatRateFormat2= {TSS|Desktop|Esarad}

  TMMFilename= {File Path}

  TMMFormat= {SINDA85|SINDA/G|ESATAN}

  OutputFilename= {File Path}

  OutputFormat= {SINDA85|SINDA/G|ESATAN}

  ValidationFilename= {File Path}

  OutputBackloadsToExcel= {Boolean}

  OutputSinksToExcel= {Boolean}

  UseT^4Average= {Boolean}

18.14 BinaryHeatMaps

Numerous Binary HeatMap blocks may exist in a session file, each defined as follows:

[BinaryHeatMap]

  ObjectName= {Valid String}

  NodeSubNetwork=  {Node1},{Node2},{Node3},...,{NodeN}

  SubNetworkLevels= {Valid Integer 1-5}

  BoundaryNodes= {Node1},{Node2},{Node3},...,{NodeN}

  TMMFormat= {SINDA85|SINDA/G|ESABLK|TAK}

  TMMInputFileName= {File Path}

  TMMOutputFileName= {File Path}

  TempFileName= {File Path}

  TempFormat= {SINDA85|SINDA/G|ESABLK|TAK}

  HeatFileName= {File Path}

  HeatFormat= {SINDA85|SINDA/G|ESABLK|TAK}

  CondFileName= {File Path}

  CondFormat= {SINDA85|SINDA/G|ESABLK|TAK}

Temp, Heat, and Cond Filename and Format are reserved for future use to allow variable formats for Temperatures, Heat, and Conductances.


19. Creating and Using the WorkBook

Once all objects and their properties are defined, the Make XL button is used to create the output Excel® workbook. During each step, progress is indicated in a progress bar for the subtask currently being performed. The program begins by processing the input file (if Node Descriptions were requested). Next, it reads the input files for each DataSet and outputs the data to the specified worksheets. Then the NodeInfo sheet is created, merging node descriptions, groups definitions, and limits onto a single worksheet. The group and parameter definitions are then appended to each DataSet worksheet as well as any Minimum, Average, Maximum formulas. All Plots are created next, followed by all Tables, Graphical Tables, RadkManipulations, Backloads, and Binary HeatMap Files. Lastly, if HeatMaps with DataSets are being generated, the Lin and Rad conductor sheets are created. Finally, the workbook is saved and the final workbook is opened in Excel® for examination by the user.

In Excel®, some macros may be available to the user if: (1) a request was made to Allow Group Modifications in Excel under the Preferences form, (2) any Parameter type object was defined, or (3) the output workbook is a HeatMap. If any of these conditions are satisfied, a TARP menu item is displayed in Excel®. Each of these items is discussed in the Heatmaps section, with the exception of the Update Groups item. Selecting this displays the form below.

Selecting a group in the tree under Existing Groups displays all nodes contained in that group in the Working Node List. Nodes contained in child groups are indicated by displaying their full path. Nodes may be moved to another group simply by dragging them from the Working Node List and dropping them into the new group in the Existing Groups tree. Similarly, groups in the tree may also be dragged and dropped into new groups to change the hierarchy. Groups may be deleted from the tree if they are no longer needed by pressing delete when the desired group is selected; a prompt is issued to delete or promote and child groups. Groups may also be renamed by entering the new group name into the New Group Name text box and clicking the Rename button. New groups may also be added as Siblings or Children of the selected group, with the new group name as specified in the New Group Name textbox. The entire group structure may be expanded/collapsed to the Major, Minor, or Sub group level. Lastly, the final collapse/expand state of the group hierarchy serves as the definition for the DynamicGroups as described in the HeatMaps section.


20. Miscellaneous

TARP.exe may also be run in command line mode for batch processing. Three arguments are accepted at the command line: -ds, -ls, and –nd. These options are described in the usage below. The –nd option is recommended when processing in batch mode to prevent TARP from awaiting a GUI response from the user.

TARP.EXE

Usage: TARP.exe –parameter [–parameter]

Where: parameter = ds          : Diagnose Startup Subroutine

       parameter = ls filename : Load specified session

       parameter = nd          : Don’t display GUI

Furthermore, three additional utilities are included: ToCSV.exe, Expand.exe, Collapse.exe. ToCSV is used to create a comma separated value file from an output file. This is useful for very large outputs which may not fit onto an Excel sheet. The user specifies the parameter to retrieve and the filename. The format is assumed based on the headers found in each type of output file (SINDA85, ESATAN, etc). The output is sent to a file with the same basename as filename, but with a .CSV extension. Expand.exe processes and executes all the INCLUDE and INSERT commands, producing an expanded file and overwriting the specified input file. Special identifying comment lines are placed at the beginning and end of an included file in order for the Collpase.exe program to be able to recognize which lines should be collapsed back to the original include file structure. Collapse.exe is the antithesis of Expand.exe and outputs a file with all the INCLUDE/INSERT commands restored. These files are all found in the installation directory.

Usage: ToCSV.exe -parameter filename

Where: parameter = T,Q,QS,QA,QE,QI,QR,Q",G,GL,GR, or C

       filename = Valid output file including path

Usage: Collapse.exe filename

Usage: Expand.exe filename

Where: filename = Valid Input file including path


- 1 -

- 3 -


- 1 -

- 4 -


- 1 -

- 2 -


- 2 -


- 1 -

- 7 -


1

- 1 -

- 2 -


- 5 -


- 1 -

- 48 -


- 3 -